Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to install MINIX 3 in VMware. I'm using Ubuntu 10.04.

I downloaded VMware, and now I am trying to install it using

 sudo apt-get install build-essential linux-headers-`uname -r`
 chmod +x VMware-Player*.bundle
 gksudo bash ./VMware-Player*.bundle

The VM Player Installer window popped up, and I clicked on the ‘Install’ button.

The progress bar started going. Above the bar, it says that the installer is ‘Configuring’. This was more than 15 minutes ago and is still going.

Nothing else is running on the system (consuming CPU, memory, etc.)

Is the ‘Configuring’ step supposed to take this long? It seems to me it might be hung.

  1. Did I do something wrong?

  2. Is there a log some place that can help me to debug this?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

You may have more luck with VirtualBox, since, unlike VMware, it is free, open, and well-supported on Ubuntu. You can download the .deb binary for your version here: http://www.virtualbox.org/wiki/Linux_Downloads

share|improve this answer

Actually, the installer goes ahead with the configuration stage only if finds gcc. So, before running the installer just: sudo rm /usr/bin/gcc (it's a symlink to /usr/bin/gcc-x.y). Run the installer and it will just stop after copying the files. Now re-create the symlink by ln -s /usr/bin/gcc-x.y /usr/bin.

share|improve this answer
    
It worked for me :) Should be the answer. –  Baptiste Wicht Apr 30 '13 at 12:12

You are likely to find that VMWare's products are not yet supported on Ubuntu 10.04 as it has only just been released. The release notes for the latest version of VMWare player only mention 9.10.

A quick search shows a number of people reporting problems with Player v3.0.1 on Ubuntu 10.04 - some report that the beta release of VMWare Player 3.1 has more luck. VMWare are probably working on it, as they tend to support Ubuntu's stable releases well as host environment, but unless you are happy running the beta you will need to wait for a future minor release.

Unless you particularly need to use VMWare, you could instead try one of the other available virtualisation solutions. For instance: a recent version of VirtualBox is available in the Universe repository for Ubuntu 10.04 (http://packages.ubuntu.com/lucid/virtualbox-ose) so install should be relatively easy via the GUI package installation/management tools or sudo aptitude install virtualbox-ose.

share|improve this answer

While it's not officially supported, I was able to get VMware Workstation installed and running on Kubuntu 10.4. It requires patching a couple of VMware kernel modules.

Since it was a fresh install, I first had to get VMware installed so I could patch the files. Unfortunately, the VMware installer is good about cleaning up after itself when it fails to install. I followed the steps outlined in http://communities.vmware.com/message/1359153 (changing the VMware bundle file name as appropriate). You may not need the killall step, but I did it.

Then, I followed the technique in the page at jbmoore61.blogspot.com/2010/02/fixing-vmware-workstation-652-and-linux.html to get the modules built and installed.

I did run into a problem with mouse input in a Windows XP guest after I got it running, but I think that problem is solved: superuser.com/questions/145524/how-do-i-stop-vmware-workstation-6-5-from-giving-up-input-focus-for-no-reason-on

(Sorry for the unclickable links; my low reputation here prevented me from posting more than one)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.