Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Does anyone know how to use Nortel Netdirect (Version 7.1.3.0) with Windows 7 64 bit (Home Premium)?

There are several ways available to me for connecting, all of which work for me on a 32-bit XP machine:

  • Nortel Contivity VPN client (v6_02.022). The installer appears to be 16-bit, so I can't even install it on a 64-bit machine.
  • Web-based SSL via IE
  • Web-based SSL via Firefox

The Web-based SSL process is supposed to load Netdirect and start it up, establishing the VPN connection.

Using Firefox, I'm able to authenticate with my smartcard, but when it tries to download the applet, the process stops with a message box saying that it couldn't download the zip file. If I run Firefox in Vista compatibility mode, it gets a little farther, and manages to start Netdirect, but then exits after notifying me that the netdirect adapter was not installed.

Using IE, I'm able to authenticate with my smartcard, then the java applet starts, but dies with the following sent to the java console:

load: class NetDirect not found.
java.lang.ClassNotFoundException: NetDirect
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: javax.net.ssl.SSLHandshakeException: Received fatal alert: unknown_ca
    at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Unknown Source)
    at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.recvAlert(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)
    at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)
    at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.net.HttpURLConnection.getResponseCode(Unknown Source)
    at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    ... 7 more
Exception: java.lang.ClassNotFoundException: NetDirect

I've tried installing certificates using java's keytool, but that didn't change the outcome.

share|improve this question
    
I have the exact issue... Were you able to find any solutions? –  Andrew Flanagan Nov 22 '10 at 22:12

1 Answer 1

As this is a 64-bit version of Windows 7, you might be able to install the 16-bit Nortel Contivity VPN client using XP Mode.

It seems to me that there are later versions than 7.1.3.0, and also that the Nortel site talks about "VPN Client (Formerly known as Contivity VPN Client)". Any particular reason not to upgrade to the latest version?

share|improve this answer
    
Installing in XP mode won't properly set up the adapter under Windows 7 itself (it can install but since it's not just an application but needs to set up adapters in the host OS, it's non-functional). I can get this to run in a Virtual PC Windows XP session, but the overhead of Windows 7 + Windows XP in Virtual PC + VPN + Remote Desktop is awful. –  Andrew Flanagan Nov 24 '10 at 17:00
    
Don't know how to get the latest greater VPN Client -- seems like distribution is somewhat... controlled. –  Andrew Flanagan Nov 24 '10 at 17:01
    
Yes, very controlled and maybe costly. Your best bet for such outdated software is a virtual machine, where XP Mode has the best integration with Windows 7 64bit. Your other option is to pass to Windows 7 32bit, where 16-bit software still has a chance to function. –  harrymc Nov 24 '10 at 17:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.