Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have packed my files in Windows 7 using Total Commander asking to use UTF-8 for file names. Then I tried to unpack my files in OS X, but Cyrillic names were messed. I have tried most programs -- none has helped me, so I had to use Parallels with Windows and Total Commander to get what I want.

Is there any other way to do it? Is it a fault of Total Commander or I need to tune OS X settings?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Assuming your decompress tool passes the raw filenames directly to the VFS layer, it's not enough for the filenames to be in UTF-8. They must also be in Normal Form D. Having the filenames in Normal Form C will end up having them mangled in the VFS layer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.