Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently haven't used my Mac Mini for about 5 days (however it was left on).

I seem to be able to connect and get great download / upload speeds through my PC, Xbox 360, iPhone and parents' laptop.

However, my Mac Mini is very slow.

OS X's Mail.app is downloading mail at 0.4kbps and then dropping to 0. Skype file transfers are doing the same. Browsing the net is a terrible experience. It is taking 30 seconds or more to download basic pages.

All of my devices connect wirelessly to a Netgear router / modem.

I have tried giving the Mac Mini a manual IP, and renew DHCP lease, as well as flush DNS in Terminal.

I have also rebooted the router / modem twice, and the Mac Mini twice.

Do you know what could be causing this? Thanks

Update

This is very weird. It is also very slow accessing localhost (setup through MAMP) and also slow to access the Netgear router config pages.

share|improve this question
add comment

7 Answers

I had the same problem. I changed the settings of the WiFi channel to "auto" and – guess what – all fine and dandy now.

share|improve this answer
add comment

My mac mini was having slow wifi issues as well. After reading that the issue is sometimes caused by bluetooth, I disconnected my old, Microsoft wireless (but not bluetooth) mouse and the problem instantly went away.

share|improve this answer
add comment

Look in activity monitor and see if anything is chewing up resources. Perhaps you have a runaway process pegging your NIC that you're unaware of.

I know this is probably a stupid question, but you're not running anything like NetLimiter are you?

share|improve this answer
    
Thanks for an answer. I'm not running NetLimiter, and the only other processes I could see when hitting Esc+Cmd+Alt were Finder and Firefox. Is there another activity monitor? –  alex May 11 '10 at 2:59
add comment

Have you tested with a wired connection? That may rule out whether the AirPort device on your MacMini is flaky or not.

Additionally, you could play with the MTU and duplex settings under the "Ethernet" tab inside the advanced network preferences for the selected network interface.

share|improve this answer
    
Have not tested with wireless, do not have the cable to do so (and hopefully it doesn't have to escalate to shifting the Mac). I will test those things. –  alex May 11 '10 at 7:33
add comment

I had a slow connection to localhost on one of my gentoo machines once before. The problem was because of my poor attempt to configure my firewall. You can test if this is the source of your problem by temporarily disabling your firewall on your mac-mini to see if that fixes the problem.

share|improve this answer
add comment

I was having the same problem with my MacBook and this is what I've discovered.

There are some apps on the Mac that interfere with the network such as VMWare, Parallels, Virtual Box. They add hidden network interfaces and this causes your Airport to degrade in performance.

I've been able to replicate the same issue on a Mac mini.

I've tested with Parallels and VMWare. Parallels appears to make the issue come to the surface faster.

Only solution is reboot OR remove the virtual network interfaces.

BTW: Activity Monitor is located un the Utilities folder. Type Activity Monitor in Spotlight to find it fast!

share|improve this answer
add comment

I had a verizon router MI424WR-GEN2 was on 'Legacy Mode' changed to 'Performance Mode' all worked fine after.

Go into Wireless Settings > Advanced Settings > scroll down to the Wireless mode and change it

'Compatibility Mode' 802.11b/g & 802.11n'
'Legacy Mode' 802.11b/g'
'Performance Mode 802.11n' <---------
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.