Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It was working just fine, until the other day I yanked it out. The wireless works just fine on the same router. If I login to a windows 7 instance on this dual boot laptop then the ehternet works just fine. So it's not a hardware, cable or router issue. The card even gets an ip, but I can't connect to the internet.

Here are the details from route, iptables, ifconfig, ping etc.

Any ideas? I have been struggling with this for day, none seems to have an answer.

share|improve this question

migrated from May 11 '10 at 3:36

This question came from our site for professional and enthusiast programmers.

have you tried disabling then re-enabling? (eg in NetworkManager)? – quack quixote May 11 '10 at 4:04

The iptables rules for the OUTPUT chain only allow the wlan0's ip address to access the domain server, which would explain why your name resolution fails.

How are those rules setup?

share|improve this answer

I had the same problem just recently, I was using a VM with Ubuntu 11.04 as the O.S. If you go to the network connection manager, you may already have a connection icon at the top.

You should have a display box showing 5 tabs, Wired, Wireless, Mobile Broadband, VPN and DSL

My display showed the only connector as eth0 and last used as 6 days ago so it was working as yours was.

What I eventually did was simply 'Add' another connection and it defaults to 'Wired connection 1'

simply enter the Device MAC address: (obtained from ifconfig) or, from the eth0 details already up and make 'Available to all users' and then 'Save'

It should connect automatically, I then deleted the eth0 that was defaulted in and kept the'Wired connection 1' as the only one in the window.

This worked fine for me on a VM as I said above but as you had yours working once it may be the same and I don't know why it didn't re-connect as the MAC addressing was the same as the newly created one.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .