Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I choose this option in network profile, turn it off, press save settings, and all seems ok. But when I open this network profile again, it shows that this option is on. WTH?

share|improve this question
up vote 1 down vote accepted

This is a common problem on Windows 7. if you're using the Windows 7 firewall you can disable Network discovery in addition to file and print sharing in the Advanced Sharing property page. If, however, you have disabled the internal firewall, you will not be able to make the settings you choose in Advanced sharing stick.

If you're using a third party firewall just block the ports ND uses, which if I remember correctly is UDP port 3702.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .