Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My user account on Windows 7 is part of the Administrators group which has a full control permissions on C:\inetpub\wwwroot:

alt text

However, when I try to create a folder in it, I get the "access denied" error. This is fixed by adding my specific user account to the list but that shouldn't be necessary should it?

share|improve this question

migrated from serverfault.com May 11 '10 at 7:57

This question came from our site for system and network administrators.

5 Answers 5

up vote 2 down vote accepted

This is expected behaviour with UAC enabled.

How are you attempting to create the folder? Windows Explorer will generate a UAC prompt, so I'm assuming you're using some other method?

If you are doing it from a command prompt, make sure it is running with elevated privileges.

share|improve this answer
    
I thought UAC might play a role here. So any folder with permissions for the Administrators group will require elevated prompt or a specific username? If so, is there any point in assigning permissions on groups with UAC enabled if I want to be able to access that files/folders from a normal, non-elevated command prompt? –  Borek May 11 '10 at 8:40
    
No, with a non-elevated command prompt your user account needs to be explicitly specified in the ACL in order for you to gain access. –  ThatGraemeGuy May 12 '10 at 7:58

The thing is though is that UAC can't "elevate" Explorer properly. See following article which explains why this happens and how to fix. I thought this was fixed in Windows 7 but appears as though it isn't, see Windows 7 Access Denied

share|improve this answer
    
This, I believe is the right answer.. –  Chandu- Indyaah Mar 4 '13 at 6:29
1  
Please summarize the relevant aspects for my upvote - otherwise we are susceptible to losing the info because the problem will probably be around longer than the website you link to (in windows 7 running on some virtual machine that will outlive us all). –  sage Apr 9 '13 at 15:58
    
Downvoting the link-only answer. And I'd -1 twice if I could for that edit begging for upvotes just as a matter of principle. It is ok, nay encouraged, to leave a link to the source of an answer, but as sage stated, without the contents the link may turn useless at some point in the future –  Tobias Kienzler Jul 9 '13 at 7:23
    
The linked article states that it is a Explorer bug. It is not. Instead, it is the result of Explorer recycling processes for several windows. You can change the behavior by enabling "Run each window in a separate process". –  gogowitsch Jun 29 at 12:55

From Technet:

To help prevent malicious software from silently installing and causing computer-wide infection, Microsoft developed the UAC feature. Unlike previous versions of Windows, when an administrator logs on to a computer running Windows Vista, the user’s full administrator access token is split into two access tokens: a full administrator access token and a standard user access token. During the logon process, authorization and access control components that identify an administrator are removed, resulting in a standard user access token. The standard user access token is then used to start the desktop, the Explorer.exe process. Because all applications inherit their access control data from the initial launch of the desktop, they all run as a standard user as well.

After an administrator logs on, the full administrator access token is not invoked until the user attempts to perform an administrative task.

So any time that you try to use admin credentials, you should be given a UAC prompt to invoke that Admin token, giving you access to make that change. Now if that is not working, you'll want to check your UAC settings.

Most likely, the setting you need to disable is the "User Account Control: Run all administrators in Admin Approval Mode". You can change that behavior by modifying the "EnableLUA" key in the following loctaion:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

That should make admins run as admins all of the time. This is dangerous and I would recommend that you turn this feature back on for day to day use.

share|improve this answer

In Windows7, administrator account is hidden. You can enable the administrator account.

  1. Click start
  2. Program - Accessories- Right click on command prompt and select " Run as" administrator.
  3. In command prompt type command type net user administrator /active:yes

It will cure it. you will 2 user account one is administrator and your user. Now you can login to windows as administrator. Now you will modify the files or even delete it.

share|improve this answer

I also had the same problem. I have done everything mentioned above but it didn't work. The problem was still on. but now my problem is solved:

  1. Manually open the folder for which the access is denied.
  2. Select the Executable/application file in that folder.
  3. Right click on it and go to PROPERTIES -> COMPATIBILITY
  4. Now see the PRIVILEGE LEVEL and check it for RUN AS ADMINISTRATOR
  5. Then click on CHANGE SETTING FOR ALL USERS.

I guess the problem is solved now.

share|improve this answer

protected by Community Apr 10 '13 at 17:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.