Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this HUGELY irritating problem on Windows 7 (x64). Whenever I click on ANY link (that exists on a Word document, Excel or Outlook), I get an alert box with the message:

This operation has been canceled due to restrictions in effect on this computer

I have been scouring my settings and the Internet for a solution, but to no avail. What is the reason for this problem? It even happens when I click anchors in word document. That is, I can't even click on an entry in a Table of Contents to go to the appropriate page - I get this same error then.

Is this a Windows 7 thing? Is there any way to turn this off?

share|improve this question

migrated from stackoverflow.com May 12 '10 at 1:27

This question came from our site for professional and enthusiast programmers.

    
If you find a way to recreate this message at will, let us know. It's so horrible it's great! A zen Buddhist would say this message has "Microsoft-nature". –  Dour High Arch May 13 '10 at 14:31

5 Answers 5

it was caused by uninstalling Chrome. This solved my problem:

if you received this error after uninstalling any application that takes over the HTML open command (including, but not limited to, Chrome & Firefox browsers) you may also need to change the HTM/HTML association in the registry.

  1. Start, click Run, type Regedit in the Open box, and then click OK.
  2. Browse to HKEY_CURRENT_USER\Software\Classes\.html
  3. Right click the value for the .html key and select Modify…
  4. Change the value from “ChromeHTML” to “htmlfile” (or from FireFoxHTML to htmlfile)

Repeat these steps for htm and .shtml keys if they exist. You may also want to check the xhtml and xhtm keys.

share|improve this answer

Did you recently uninstall Google Chrome?

I use Windows 7 64-bit and can replicate this exact behavior. After uninstalling Chrome all links in Office applications (OneNote, Excel, Outlook etc.) do not work anymore. After reinstalling it ... no problem. You do not have to use Chrome ... my standard browser is Safari.

Don't forget to Log off / on. Technically it has something todo with an all upper case entry in the registry. However I did not figure out yet all the places or the exact procedure required to fix this without having Chrome installed. Also: I feel it should be the task of the Google folks to write and distribute that fix.

share|improve this answer
    
We had his exact problem. Installing Chrome again fixed it. –  Stephen Jennings May 14 '10 at 2:59

This operation has been canceled due to restrictions in effect on this computer..

I had the same problem with windows 7 and office 2007, and then surfing the web, I found a fix fro Microsoft and download it, after installing the problem was resolve it.

Here is a link with the instructions and the file to download:

http://support.microsoft.com/?kbid=310049#fixit4me

share|improve this answer

This was driving me crazy until I found Alan's quick fix here.

I found that re-installing Google Chrome or FireFox and setting it as the default, the hyperlinks worked. I then went to Internet Explorer and set it as the default browser. I again checked the hyperlinks, and again they worked. I then un-installed Google Chrome and have had no problems since. Hopefully this will work for others as well.

share|improve this answer

This can happen if a program has changed the default opening program for html files. I ran into it when I set Notepad++ to open .html by default.

share|improve this answer

protected by Community Jul 10 '13 at 18:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?