Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Cambridge Z88 that I want to get working with my PC.

Around 6 years ago - in 2004 - I made heavy use of my Z88 to do a whole bunch of writing on the train while commuting to and from work. The Z88 is solid state, lightweight and has a full size silent keyboard, so it works very well as a writing instrument.

I still have the serial cable I soldered up back then and used successfully in 2004. It has these connections:

   Z88           9 pin
  -----         -------
  2 TxD ------> RxD 2
  3 RxD <------ TxD 3
  7 GND <-----> GND 5
  4 RTS ------> CTS 8
  5 CTS <-+     RTS 7
  8 DCD <-+---- DTR 4
  9 DTR ----+-> DCD 1
            +-> DSR 6

Unfortunately, I haven't been able to find my notes from 2004 that describe how I got it to work back then. I've spent several hours trying to Google a result, but to no avail.

I'm pretty sure the cable is fine - after all, it's what I used successfully six years ago, and I've checked it out with a multimeter - so I'm focusing on the PC end of things, which is where I'd like some assistance.

Q1: In my recent attempts, I've been using both Hyperterminal (as built into Windows XP) and the command line (copy com2: con:), but with no success. What's a good (better!) serial communications application to use? Is there one that allows me to see as deep as the signalling that's occurring on the wire?

Q2: If you have a Z88 that works correctly with your PC, what software do you use on the PC end, and what's the pinout of your cable?

I'm pretty sure that the Z88 itself is working properly: When using the built in Import/Export tool to send a file, I see different behaviour when my serial cable is connected compared to disconnected. When disconnected, the transmission appears to work, with a progress meter counting up and then finishing; when connected, nothing happens 'cept a timeout if I wait long enough.

Update: My problem was my serial cable - not the custom adapter I made (with the pinout shown above), but the regular standard serial cable I was using. As soon as I switched to a different one, everything started working perfectly.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Have you seen Z88Transfer?

z88

http://www.rastersoft.com/programas/z88transfer.html

share|improve this answer
    
No, I hadn't seen it - looks like it might be just what I need. I'll give it a go and report back. Thanks! –  Bevan May 12 '10 at 7:42
    
Unfortunately, I couldn't get this to work. Based on some diagnostics, I think that the hardware flow control built into my custom Z88 serial adapter is getting in the way of this program working as it should. I'm going to persevere though - if I can get this to work, it'll be awesome. For the moment, though, "printing" from my Z88 into a terminal window on my PC is working fine. –  Bevan May 13 '10 at 9:33
add comment

I assume that your connection drawing is incorrect. You meant...

Pin 2 - Pin 3 'TX to RX
Pin 3 - Pin 2 'RX to TX
share|improve this answer
    
You'd be correct if the Z88 had a standard serial port, but it doesn't. It has a non-standard, proprietary pin-out. The connection drawing I gave correctly describes my custom serial adapter. –  Bevan May 19 '10 at 7:00
    
If the names under the columns are correct the Z88 is standard, pin 2 is TD, 3 is RD, 4 is RTS, etc. If you hook Pin 2 to Pin 2 nothing will happen, nor should it. –  dbasnett May 19 '10 at 11:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.