Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem installing Firefox without root privileges.

Mozilla says the following:

Firefox will not run at all without the following libraries or packages:

* GTK+ 2.10 or higher
* GLib 2.12 or higher
* Pango 1.14 or higher
* X.Org 1.0 or higher

Of course i need to install all these dependencies without root privileges as well, but the thing is i don't know exactly how to do this. I've tried a few things i found on the internet, but to no avail.

share|improve this question
add comment

3 Answers

Hah. You can't install them. You would be able to copy them as a binary then link the source package to these binaries, and then put it into your folder with all the dependencies ...and.. WAIT. That would take a few days for an expert also.

Give up. If you dont even have a Xorg... you wont be able to start it since that is the GUI for linux (and so on but that doesnt matter now). Xorg cant be installed like that (the others are possible, not an easy job though).

share|improve this answer
    
Im not sure which version i have for each of these packages. These requirements are just picked from the website. I know i need the glib and gtk for sure, the rest i'll have to give it a shot i guess. Maybe you know of another browser which is debian compatible and can be installed without root privileges? –  Ivar Lugtenburg May 12 '10 at 10:59
    
Oh this sounds way better. I mean... at least now we can have a start point. So.. lets see. What do you have on the system? Try starting the browser by downloading the binary package from mozilla.org , unpacking it and typing: ./firefox (for example, whatever the start file is). Try it, it should throw out what does it need. –  Shiki May 12 '10 at 12:30
add comment

You can build Firefox statically from sources on an uptodate debian system, get the staticaly built binaries, and try to run it on your old system.

A statically built binary means that all the lib it depends on are included in the binary itself.

share|improve this answer
    
There's no need to do that in general. Most distros already have all the necessary libs. Plus, building FF is not necessarily trivial... –  sleske Jun 16 '10 at 10:40
add comment

The dependencies you listed are already part of most reasonably recent Linux distros. Even Debian stable (aka lenny) already has them all. Almost all graphical programs require them, so if you have a desktop environment running, they will already be installed.

In that case, you can just grab Firefox from http://www.mozilla.com/en-US/firefox/all.html (choose the Linux version in your language). You'll get a .tar.bz2 archive; just uncompress it with

tar -xjf firefox-xxx.tar.bz2

in the directory where you want to install it, e.g. in your home dir. Then you'll get a new directory "firefox". cd into it, and run

./firefox

That's it...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.