Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like to watch Windows media center recorded TV files on my laptop in bed. I find thought that when the programs are in HD I have a lot of stuttering and delays--no doubt b/c of the amount of data being transferred.

I actually have a fair amount of space on the laptop's hdd, and wouldn't mind moving the files onto that hard drive, where no doubt my problem would go away. But that requires some planning & time for the files to move.

Is there a utility out there that would kind of 'trickle' the files over to the laptop over a long period of time, w/out soaking its bandwidth? Something like Microsoft' BITS tech?

Both machines are running Windows 7.

share|improve this question

4 Answers 4

Just use the easiest solution. Download SMplayer, set the cache large enough (you can go to 25000kb even or more) and try with that. Definitely fixes your problem. (Download the portable 7z version, no need to install it.)

Explanation. Mplayer is a very versatile and awesome player. SMplayer is a frontend for that. You can replace the in-built mplayer (which comes with smplayer) with a few clicks (for better performance. And you can use the 'ffmpeg-mt' version.). Grab your copy from the linked site (ffmpeg-mt is using the multi cores also), place it in the unzipped smplayer folder. Open SMplayer and select the mplayer binary in the options.

Other solutions are using TeraCopy or Total Commander. (You can specify the transfer speed or pause it.)


If the performance is the problem. Install CCCP pack , launch Media Player Classic HC and go to settings. There, go to Internal Filters and on the far right column, select the H264/AVC(DXVA) and the VC1(DXVA) ones. Close mpc-hc and start your movie with it. If everything is OK, you should be able to play it without a problem, and mpc-hc switches to "Playing[DXVA]" at the bottom.

NOTE: This works with ANY video card. However, you can also use CUDA acceleration with NVidia cards. You need a 8600 or higher NVidia card for that, and a "CoreAVC" codec. (Its proprietary, not free, however its the best.) Buy it, install it, launch Start -> Combined Community... -> Filters -> ffdshow video configuration. Go to Codecs at the left and at the H264/AVC, select disabled instead of the "libavcodec". (mpc-hc lets you use ffmpeg-mt also as you can see it here). Restart your mpc-hc/playback, there you go. :)

share|improve this answer
    
Thanks for the response! I'm not seeing wtv on the list of mplayer input formats--do you know if smplayer will handle those? –  Roy Pardee May 13 '10 at 2:33
    
Guess there is no other way, just try it. If SMplayer fails, you can try a "KMplayer portable" (it comes with DXVA but I just can't stand that media player. Always got some problem.. usually if the file is corrupted, mplayer/mpc-hc plays it flawless. KMplayer wont even display subs, wont even work. Ehh. (But a lot of people love that player.)) –  Shiki May 13 '10 at 4:23

Try NetLimiter. This can limit bandwidth usage of certain programs. I'm not sure if it works on Win7 though, I used it on XP.

share|improve this answer

Are you sure that your problem is network I/O? Because even on a wireless network it shouldn't be, unless you're watching 1080p Blu-ray rips. I don't mean encodes, I mean the raw rips.

h.264 is CPU-intensive to decode though. Make sure your problem isn't that the CPU isn't fast enough to do the decoding unassisted.

share|improve this answer
    
Ah, good question! I just now copied a file over (a 3GB .wtv file--took about 25 minutes over wifi) and it ran flawlessly. So I think it is a network issue. –  Roy Pardee May 13 '10 at 3:04
    
Was the video shorter than 25 minutes? –  afrazier May 13 '10 at 3:20
    
It was an ep of a 30 minute show, plus margin time--just shy of 35min. –  Roy Pardee May 14 '10 at 14:00
    
If you're running 802.11g, then that's at the ragged edge of working. Any hiccups in bandwidth could cause a stutter. If there's a way to tune the memory used for a playback buffer, it could smooth out playback. –  afrazier May 14 '10 at 14:40

I think the HDD activity is interfering with the prefetching when watching your vids...personally I would set up a ftp server and have bandwidth limits but it prob wont solve the core issue. If you haven't already try bumping up the cache as suggest earlier and adding more ram to your system if you haven't maxed it out yet.

share|improve this answer
    
Thanks! By cache, do you mean a windows media center cache or OS or...? The laptop has 3GB of ram--I'll definitely look at upgrading, but it seems like that should be plenty I would have thought. –  Roy Pardee May 13 '10 at 2:40
    
3GB is a plenty and its more than ever needed, more than enough. In a laptop its not the best to max it out. Things like hibernation will get slower, so think about it wisely. My ThinkPad supports 8gb ram as far as I know, but I just dont want to go behind 2gb since hibernation would take a lot of time. (Maybe when I'll get an Intel X25M ssd , I'll buy 8gb ram..but before that, I wont buy anything...) –  Shiki May 13 '10 at 15:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.