Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Google Chrome as my web browser on MacOS X Snow Leopard. I am a keyboard shortcut addict, and I use QuickSilver to create keyboard shortcuts for anything I can. One of the most common things that I do is to open a new web browser window. But I use Spaces frequently to partition my tasks that I am currently working on, and when I open a web browser or web page with a QuickSilver trigger, spaces switches to the last space that I used Chrome on and opens a new tab, which often distracts me for hours because it brings me to a different space and thus a different task.

I can fix this by right-clicking on the Google Chrome icon and clicking the "New Window" option, which opens a new window on the current space. I have tried to compose an AppleScript to do something like this, with no success. It has become a serious problem. Back when I used Firefox, I solved the problem by changing a preference item that says "Always open pop-up links in a new window" or something like that, which was kind of a sledge hammer approach, but it worked. I can always go back to Firefox, but I thought I'd ask my question here first. Anyone with any ideas?

share|improve this question

5 Answers 5

Did you uncheck the "When switching to an application, switch to a space with open windows for the application" checkbox on the Expose & Spaces preferences pane, in System Preferences?

share|improve this answer
    
even with this unchecked, the problem persists (in 10.8). it seems to open a new tab in the most recently selected chrome window, even if there is an open window in the current space. –  John Bachir Feb 21 '13 at 16:49

I agree this is annoying. You can drag the tab off of the Chrome window, and drag it into the new space (which is what I typically do).

share|improve this answer

Spaces is transparent to the applications. If applications don't want to know about Spaces, they don't need to.

As you pointed out yourself, you have the option in Firefox to open web pages either in the same, frontmost browser window, or a new window. Since Firefox doesn't know about Spaces, you switch spaces, back to Firefox' frontmost window, in the former setting. In the latter setting, you open a new window, which can be accomplished on your current space.

There is most likely no way to get the behavior you want. Your best bet is to find a "sledge hammer" option similar to that in Firefox.

share|improve this answer
up vote 1 down vote accepted

The best solution to this problem involves Applescript. See this answer that I got by posting a related question on StackOverflow.

share|improve this answer

Perhaps you should consider looking at how Chrome's process model is interacting with Spaces. I am really only guessing, but perhaps one of them will play nicer with Spaces.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.