Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been sent an Excel spreadsheet with a weird first row. Some of the cells say "Column1", "Column2", etc., but I can't delete their contents. If I select the cell and hit backspace, it goes blank, but when I press return, it goes right back to saying "Column1".

I found another answer here that suggested this could be caused by "Cell validation", but the validation window says "Any value", and also "show alert" (and I'm not seeing an alert), so I don't think that's it.

The first row is white text on a blue background, if that means anything. The spreadsheet was sent to me in XLSX format, but I tried resaving as XLS and opening that, and it seems to make no difference.

This is with the "ribbon" version of Excel (they got rid of the Help menu so I don't know how to see what version number it is!).

Thanks!

Update: The Excel online help says to use ribbon Home tab -> Cells -> Delete -> ... to delete cells. When I select anything on the first row, this pop-up menu is dimmed. So maybe Excel doesn't think row 1 consists of "cells"? Though I don't know what else it would call them.

Update 2: I found it, kind of. If I click the "Design" tab in the ribbon, then uncheck "Header Row", then first row becomes a normal row of cells again. Unfortunately, the contents disappear entirely. I want to delete a few cells, not all 50+! And if I copy the first row before turning off "Header Row", it disappears from the clipboard when I uncheck that. So I kind of know what mode it's stuck in, but not a good way out of it.

share|improve this question
    
Re: finding the version number of 'ribbon' versions of Microsoft Office: see How do I find the version number in 'ribbon' versions of Excel? –  Peter Mortensen Jan 24 '12 at 13:51
1  
I had a similar problem, but the Update 2 was the solution: merely unchecking the Header Row option in the Design tab. +1 for that. Microsoft gets a -1 for the ribbon. –  JYelton Mar 12 '12 at 16:49

1 Answer 1

up vote 5 down vote accepted

The person who sent me the file (who is an Excel master) showed me the solution just now:

Select All, right-click, Table -> Convert to Range.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.