Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Mac OS X 10.6 on a 17" MacBookPro 4.1 with a Core2 Duo. But the install says:

Mac OS X 10.6 cannot be installed on this computer.

Any ideas why or, better yet, workarounds?

share|improve this question
Is this an upgrade install or a clean install? If upgrade, what version are you upgrading from? – Troggy May 12 '10 at 20:49
I've tried both: first I tried to upgrade from 10.5.8 and got the error, so I wiped it and tried a clean install, then I reinstalled and updated to 10.5.8 and have tried again. – ConsultUtah May 12 '10 at 21:02
Is this a retail 10.6 DVD or is it a 10.6 system DVD that came with a new Mac ? – Paul R May 12 '10 at 21:15
up vote 2 down vote accepted

There are two options

  1. You are trying to upgrade from a version that is not Leopard , or an early version of Tiger (< 10.4.4, according to the SL DVD I have). If so, back up your data to an external drive, format the MacBookPro's drive and make a clean install. This should work even if you only have an "upgrade" SnowLeopard DVD.

  2. You are using an install disk that accompanied another (more recent) Mac. In this case, rip the disk, use "Show Package Contents" on the installer and find the file Info.plist. If you have Xcode installed you'll have access to Property List, but you can also edit Info.plist in any text editor. What you'll be looking for is a key-value pair that is used for checking the install restriction. Change the value, save, and burn the image onto a DVD (or for speed install from a USB stick, but that needs some more steps).

Since Apple changes the install disks every now and then, this procedure may not work exactly as described, but you get the general gist of it.

share|improve this answer
I was using the wrong disk. Plugging in the upgrade disk worked fine. – ConsultUtah May 20 '10 at 4:30

Sometimes this has to do with the version of the disc versus what the hardware shipped with or what it expects. Are you using the install media that came with the machine or something newer?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .