Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded the wireless network card in my Ubuntu PC from an 802.11g to an 802.11n.

Now, it can't see my router. It doesn't appear in the list of networks that is displayed when you click on the NetworkManager icon in Gnome. Other networks are listed and I have connected to them (no password required!).

I'm using the Windows driver through ndiswrapper and it can see the card. I tested the card in a Windows PC and everything worked.

The router's log doesn't show any messages coming from the wireless card.

What have I done wrong?

If you need any more information, just leave a comment and I'll get add it to the question.

share|improve this question

2 Answers 2

Did you keep the same router? Any chance your router is an ETSI (European) model on channel 12 or 13 and your new N card is an FCC (American) model which doesn't support those channels?

share|improve this answer
    
There is a new router. I bought the router and card at the same time from the same retailer. They are both by the same manufacturer (TP-Link). –  Skizz May 13 '10 at 6:31
    
Also, I've tried the wireless card in a Windows PC and it worked great. The problem is that, when pluged into an Ubuntu box, the card fails to see the router (but can see an open network nearby) –  Skizz May 13 '10 at 14:08

It could be that you have a mismatched mode (G or N) between the router and the wireless network card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.