Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having trouble starting up Ubuntu (Karmic). Bascially I get to the bit where the log in dialog is supposed to appear, but it doesn't.

Is there a hot key of some sort to force the login dialog to appear?

Thanks!


Full details here: http://ubuntuforums.org/showthread.php?p=9290145#post9290145

share|improve this question
1  
I believe this has to do with Ubuntu switching Nvidia drivers in a recent update. See this and this to see if they help. –  Dennis Williamson May 13 '10 at 10:58
add comment

1 Answer 1

up vote 1 down vote accepted

Ctrl+Alt+Backspace is the traditional Kill-X-Immediately shortcut (aka "DontZap"), but it's been removed from the X-server in recent versions. It's not enabled by default, but there are various methods to enable it.

If you can login on the text console, or if you've installed the SSH server on the machine, you can use those methods to enable DontZap, or you can use one of these commands to restart GDM:

sudo /etc/init.d/gdm restart
sudo restart gdm

Another option is the Magic SysRq keys. Be very careful with them, but if necessary, they may be useful. The DontZap wiki article adds this:

For anyone missing the ability to kill the X-server in emergency, may I point out Alt+SysRq+R, followed by Ctrl+Alt+F1 (the first puts the keyboard back into Raw mode, i.e. outside the control of the X-server; the latter switches Virtual Terminal.) Or you can use Alt+SysRq+K to kill the current session.


From your Ubuntu Forums post, it really sounds like you've loaded an incompatible graphics driver (or maybe just an incompatible setting). Use bryan's suggestion to test the graphics hardware by booting to a LiveCD; if that works you can focus on uninstalling or reconfiguring the broken graphics driver.

share|improve this answer
    
♦ : Is it possible that my graphics driver is incompatible/ not working, even though it was working fine in GUI-mode (X-server), and only seesm to be problematic in terminal mode? –  bguiz May 13 '10 at 8:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.