Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As soon as I logon to Windows 7 64bit, the computer restarts.

It isn't a hardware issue, as linux works fine.

Windows 7 64 bit.

Safe mode, last known good configuration etc, nothing makes any difference. Nor does startup repair or sfc.

I used DaRT to check the event log, and nothing is recorded.

How can I troubleshoot this?

share|improve this question
1  
How do you know it is not a hardware issue, just because Linux doesn't reboot doesn't make it a software issue. What is Windows has drivers for a particular piece of hardware that is causing the reboot, whereas Linux doesn't have the driver and the device is not being activated under Linux? –  ta.speot.is May 13 '10 at 5:09
    
Because I was using Windows perfectly until I installed an update, and I use Linux in the exact same way. I have not added or changed any hardware since. –  Jack May 14 '10 at 6:30
    
That is important information. Which update was it that you installed? –  mand0 Jul 8 '10 at 19:21

3 Answers 3

When booting Windows, press F8 repeatedly. At the menu, disable auto reboot. You will likely get a BSOD with a stop error. Note the stop error and look it up on the net. There are many things that could be happening, but this should get you started.

share|improve this answer
    
I should have said in my question that that didn't work either :( Even with automatic reboots disabled, it reboots. –  Jack May 14 '10 at 3:51

Are you sure its not a software error thats causing it like maybe a virus? And quite possibaly it could be a hardware error for hardware that Linux isnt using. Maybe your drivers are corrupt? MAybe your best bet is to use linux back up everything and do a factory reset or a hard format. This would eliminate the software issue.

share|improve this answer
    
Even if it is a software problem, I should be able to see what the problem is - even if I can't fix it. –  Jack May 14 '10 at 3:50

If it reboots with auto-reboots disabled, it's more than likely a temperature issue. Your power is being cut to keep the processor from overheating (regardless of how likely that may be).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.