Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I reach left-most end of a line and press left-arrow it doesn't take me to the previous line.

Similarly, if I keep pressing right arrow, the cursor keeps going towards infinity, without ever moving to the next line.

How do I change this behavior to desired one?

share|improve this question

Find Tools -> IDE Options -> Editor (in OSX it's Preferences -> Editor). In the area entitled "Virtual Space" uncheck "Allow placement of caret after end of line". Click "Apply" and you're good to go.

share|improve this answer
1  
See also my reply to the same question at StackOverflow: stackoverflow.com/questions/4493697/…. – CrazyCoder Aug 23 '11 at 11:07
1  
That's not the preference location, possibly due to a menu change. To find it I used Help > Find Action > "Virtual Space" – Chip McCormick May 5 '14 at 21:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .