Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to run Squeezebox server on my Mac running OS 10.6 Snow Leopard. The Firewall settings on 10.6 now let you speciy by Application things that are allowed to connect through the firewall. But Squeezebox server isn't an application, so I can't select it.

If I turn the firewall off, it works fine. This is a reasonable step for a desktop (as it's always connecting to the 'net through the router's firewall) but on a laptop that connects via public WiFi it doesn't seem like a good idea.

Help!

share|improve this question

2 Answers 2

It turns out there is a way to do this, although I'd be nice if there was a better way. You can add command-line applications to that allowed by the Firewall settings, and as the Squeezebox server is just a Perl script, if you add /usr/bin/perl to the list of apps allowed, then it works ok.

When you go to add an Application to the list, you can't see the /usr directory listed, even from the root of the disk, so you have to symlink the /usr/bin directory to somewhere that is visible, and then you can navigate to the appropriate directory & select perl.exe. Once you've added perl.exe to the list, you can remove the symlink.

share|improve this answer
    
You need to use the Terminal.app from Applications/Utilities. In that enter ln -s /usr/bin link-to-usr-bin Which will create a link-to-usr-bin directory link in your home directory. –  Jonathan Caryl May 15 '10 at 12:30

There's another way to get this to work: in the firewall advanced settings dialog if you uncheck the 'Enable stealth mode' option then you should see it ask whether you want to add Perl to the list of apps allowed, rather than have to jump through the hoops of symlinking and adding it to the list manually.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.