Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer that is new, Windows 7, that is supposed to have access to particular network resources on a Distributed File System. However, despite all permissions being set correctly, I have consistent trouble accessing them.

For instance, I'm supposed to be able to reach \company.org\main\subdir. All the permissions have been granted, only when I try to access it by name, it tells me I don't have permission to access \main.

This is where the fun starts. If I ping company.org, get the IP, replace company.org by the IP, I can then access \IP\main\subdir without any problems at all. However we have a ton of scripts and build tools that access the network resource by name.

My sysadmin has found that using MS's dfsutil.exe, we can fix it temporary using this sequence of commands:

C:\dfsutil.exe /pktinfo
C:\dfsutil.exe /PktFlush
C:\dfsutil.exe /SpcFlush
C:\dfsutil.exe /PurgeMupCache
C:\dfsutil.exe /pktinfo

After that, everything is great... until I reboot, or until some unspecified time later where suddenly I don't have access to \main\ anymore.

Hoping to find a more permanent solution than waiting for it to break and running a batch file.

share|improve this question

1 Answer 1

dfs is site aware, do you happen to know if your in a multisite dfs infrastructure?

share|improve this answer
    
I believe so, there are servers all over the world. –  Charles Randall May 13 '10 at 17:51
    
is main\subdir a dfs entry thats replicated? Also is the site info correct for the given subnet. run this "dfsutil /pktinfo" it may give you some hints as to what the problem is. –  user33788 May 13 '10 at 18:27
    
When I run that and the problem is active, it lists under --mup.sys-- what I can only assume is every volume, and says "State:0x00". When I run my batch file to fix it and run it, it says "0 entries..." –  Charles Randall May 18 '10 at 13:46
    
do you see multiple servers hosting main\subdir? If its a dfsr link you should see multiple servers with one being active, the one being active is it in your local subnet? Also is this an AD integrated DFS root. The issue being that if your settings permissions on the wrong server within the dfsr path then perms will change based on site topology changes and you need to find the correct server to make the changes on. –  user33788 May 18 '10 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.