Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently had data recovered and it was sent back to me on what I think is an NTFS drive. I copied all the files over to a file share I have on a Linux box, that's ext4. Now I have that share mounted on my OSX machine, and I can't move or rename most of the files. However, in a couple cases I was able to rename a folder after the third try. Another time I was able to rename a folder once, but not again. All the permissions are showing up the same on the command-line -- I can't see any differences between the permissions on any of the files/folders.

Note that I can create new folders and add files no problem, and then rename and move those all I want.

Any clues???


share|improve this question
Are you doing this through the command line or a GUI? Is there a specific error from the command line? – Nitrodist May 14 '10 at 8:38

Try to select a file that has been causing problems and right-click it in Finder, then select Get Info. In the pop-up window, see if the Locked option is checked, and try to deselect it (it may require authentication).

To note that even if the POSIX permissions are the same, the files may have different ACLs that take precedence. You can see what they are by opening a Terminal window (Applications > Utilities), navigating to the folder that contains some of the problem files, and typing ls -le. Post that output here if the first suggestions doesn't help.

share|improve this answer

I just ran into the same problem, and I found the 'Locked' box checked when I do Get Info from finder. However, I find it annoying to have to do such things outside the terminal..

See this apple article:, section: Advanced tip about deleting locked files

which will direct you to: chflags -R nouchg files

ls -l won't show any difference, but ls -lO will (that's capital oh).
man chflags for more info

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .