Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open a bash terminal in OSX and then type Alt + F to got back one word it instead opens the find dialog? Many of the other key-bindings have similar problems. How can I change this?

share|improve this question
    
Related discussion in this question: superuser.com/questions/139444/… –  Doug Harris May 13 '10 at 21:50
add comment

2 Answers

up vote 2 down vote accepted

Preferences->Settings check the "Option as Meta Key" checkbox at the bottom.

share|improve this answer
add comment

Ctrl-rightarrow.

You have the ctrl button one to the left of alt (option), this does everything in the terminal just like it would on a regular qwerty keyboard(windows, linux).

You can also use ctrl shortcut in the rest of your osx applications for a lot the same functions like end of line ctrl-f and beginning of line ctrl-a.

A very similar question was asked on stackoverflow and it has some really excellent answers already.

http://stackoverflow.com/questions/81272/mac-os-x-terminal-move-cursor-word-by-word

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.