Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am configuring a Linksys SRW2024 and accidently changed the management VLAN before changing the VLAN configuration. Thus, I can no longer access it.

The only way I have read to get into it now is via a console cable. The laptop I'm using right now (MacBook Pro) has no serial port. Given that I am currently unable to get my hands on a serial port adapter, I thought I would try on a Linux box.
I have a CentOS 5.4 server here (PowerEdge R300) that I am trying to use to talk to the switch.

I tried minicom first but I do not see the console. Another site suggested the screen command. I tried

screen /dev/ttyS0 38400

but all I get is blinking cursor. I do not see the configuration. I don't know if anyone here as any tips but I hope someone does.

Thank You

share|improve this question

1 Answer 1

I'll bet both your R300's serial port and the SRW2024's serial port are male DB-9 connectors, indicating that they are both DTEs (Data Terminal Equipment, like a VT100 terminal or a PC), indicating that you need a "null modem" cable to connect them. Typical serial cables are for connecting DTEs to DCEs (Data Communications Equipment, such as modems). When you need to connect two DTEs together without a pair of modems and a phone line in between, you need a "null modem" cable, which is what we call a serial cable wired for a direct DTE-DTE connection.

If you're already using a known good null modem cable between them, the next thing I'd try is seeing if maybe someone set the SRW2024's serial port to a different speed. I'd try 115200, 9600, 230400, and 57600.

Another thing to try is power-cycling the switch while watching the serial console (use the SRW2024's default of 38400 for this). I seem to remember that it uses the default serial port speed at boot time, and gives you some factory reset options at boot time, before it reads your saved settings. So maybe you can get in that way.

share|improve this answer
1  
Thank You, I ended up having to get a Serial to USB Adapter which worked great to connect my laptop to the router. –  sxanness Jun 21 '10 at 18:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.