Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just uploaded an overwrote an image with the exact same file name on to my site, but the old image is still showing up. Is there a delay sometimes in updating the images? Do I have to change the code if it is just an image with the same name?

share|improve this question
1  
Try hitting Ctrl+F5 in your browser. –  heavyd May 13 '10 at 20:42

3 Answers 3

up vote 2 down vote accepted

Are you sure that you haven't cached the image in your browser? Clear your cache and then try again or use another browser that you haven't visited that site with or hit F5 (or ctrl+f5) to force a refresh of that page/resource.

share|improve this answer
    
no.. unfortunately that wasn't it. Just gave it a try. –  user36992 May 13 '10 at 20:46
2  
If that wasn't it, why the accepted answer? If it was correct, please delete your comment. –  heavyd May 13 '10 at 22:09
    
Indeed, I am perplexed as well. –  Nitrodist May 13 '10 at 22:18

FTP isn't prefect, try erasing or renaming the old file, then re-uploading it. I've found many ftp clients for me on mac os x simply do not overwrite succesfully even though they report that they have.

share|improve this answer

Several things to consider, all of which I've run into:
1) Make sure to clear the cache
2) Make sure that you're copying to the correct folder. (this one drove a user nuts trying to figure out what what was happening.)
3) Make sure the file size has changed. If the file size is the same, delete the remote file and replace it.
and probably a few other things that I don't remember right now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.