Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to install Gaphor successfully by Easy_install

$ sudo easy_install gaphor
Searching for gaphor
Best match: gaphor 0.14.0
Processing gaphor-0.14.0-py2.5.egg
gaphor 0.14.0 is already the active version in easy-install.pth
Installing gaphorconvert script to /usr/local/bin
Installing gaphor script to /usr/local/bin

Using /Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg
Processing dependencies for gaphor
Finished processing dependencies for gaphor

I run it unsuccessfully by

$ gaphor
Traceback (most recent call last):
  File "/usr/local/bin/gaphor", line 8, in <module>    load_entry_point('gaphor==0.14.0', 'console_scripts', 'gaphor')()
  File "/Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg/gaphor/__init__.py", line 65, in main    launch()
  File "/Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg/gaphor/__init__.py", line 36, in launch    from gaphor.application import Application
  File "/Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg/gaphor/application.py", line 16, in <module>    import gaphor.UML
  File "/Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg/gaphor/UML/__init__.py", line 3, in <module>
    from gaphor.UML.uml2 import *
  File "/Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg/gaphor/UML/uml2.py", line 97, in <module>
    from diagram import Diagram
  File "/Library/Python/2.5/site-packages/gaphor-0.14.0-py2.5.egg/gaphor/UML/diagram.py", line 12, in <module>    import gobject
ImportError: No module named gobject

I then install gobject and run sudo port install py26-gobject. However, the same problem persists.

How can you install Gaphor to OS X by MacPorts?

share|improve this question
1  
istall ? – Bruce McLeod Jul 28 '09 at 1:02
up vote 1 down vote accepted

You are missing GObject for Python 2.5.

Run:

sudo port install py25-gobject

Gaphor should work after this.

share|improve this answer
    
@Mike: Why is it using Python2.5? --- OS X Leopard's default Python is 2.6.2. – Masi Jul 28 '09 at 19:26
    
I get the same error after removing py26's apps and installing the app. – Masi Jul 28 '09 at 19:31
    
If you look at the output it's using 2.5. Leopard's default is 2.5.1, you are maybe getting confused with MacPorts. – Mike McQuaid Jul 28 '09 at 19:34
    
I fixed the title - thank you for pointing that out! – Masi Jul 28 '09 at 20:30

You didn't install with MacPorts, you installed with the system Python install.

instead, try

sudo /opt/local/bin/easy_install gaphor

As Mike said you may need support libraries installed with macports

share|improve this answer
1  
Doh, didn't even notice that he didn't actually use MacPorts! – Mike McQuaid Jul 28 '09 at 19:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .