Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Upon starting Windows Server 2008 R2 I get this error message:

Event ID 11 Disk

The driver detected a controller error on \Device\Harddisk3\DR3.

There are also also 3 more similar messages for Harddisk 2, 4, and 5, but not zero or 1.

Checking the event viewer reveals it's been going on for 3 months.

I ran chkdsk - no bad sectors.

Any advice on the cause, better still, a solution?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I saw these errors when one of my RAID controllers was failing. You may find the below knowledge-base article helpful, although it provides general starting points rather than in-depth troubleshooting.

In almost all cases, these messages are being posted due to hardware problems with either the controller or, more likely, a device that is attached to the controller in question. The hardware problems can be associated with poor cabling, incorrect termination or transfer rate settings, lazy or slow device responses to relinquish the SCSI bus, a faulty device, or, in very rare cases, a poorly written device driver.

http://support.microsoft.com/kb/154690

Note that it can also be caused by using consumer grade drives with a RAID controller that expects writes to complete quickly. Although a write using a consumer grade drive my complete successfully, the RAID controller will report a timeout. I think Western Digital drives are more prone to this than any other.

This may also be helpful.

share|improve this answer
    
Thanks for the info. However, I should have mentioned that I had scanned those kbs, but dismissed them as I don't have SCSI, RAID or Clusters. Just a basic disk system. –  Guy Thomas May 14 '10 at 11:48
    
The disk controller can still be bad on the motherboard. If they are SATA, try changing from AHCI to IDE emulation and see how it goes. –  ta.speot.is May 14 '10 at 12:32
    
How dangerous is changing AHCI to and from IDE? –  Guy Thomas May 14 '10 at 14:56
    
AHCI to IDE should be pain free, the other way around causes problems. As long as you have regular backups changing any setting shouldn't be a problem. –  ta.speot.is May 14 '10 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.