Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a ssh key using:

ssh-keygen -t dsa

But when I use FileZilla (FTP) to my server, I can't see the .ssh folder or files. I even tried moving the id_dsa file to another folder but I still cant' see the file.

Is it hidden?

share|improve this question

According to your post your server is a *nix machine. Therefore .ssh is a hidden folder. You need to enable your FTP-Client (here Filezilla) to show hidden directories/files. Afterwards the .ssh directory will show up.

share|improve this answer
Had a similar problem using FileZilla - it wasn't clear to me at first how to view hidden files. The option to show hidden files (in version 3.5.3) is under the Server menu: "Force showing hidden files". Not under Edit|Settings as I would have expected. – Shannon Wagner Feb 18 '12 at 13:33

If you're using the same account, it should show up. Unless you're on a windows machine. There may be an options to show hidden files & directories (in unix, the .ssh is a hidden directory).

Otherwise, you can try using scp to copy your file

scp ~/.ssh/id_dsa

share|improve this answer

IF you are able to login to the remote server but public-key authentication does not work,
it could be because the .ssh files are not in the home area that you see after you login.

Have you tried looking at the log files on the server?

# Any, other server specific logging? maybe you need to enable it?

I have not used FileZilla first-hand, don't have details.
There must be some way to go verbose and check what is failing on the auth path.

share|improve this answer

SSH pair key authentication is very picky about permissions. I wouldn't try to set up the folders and keys with an FTP application. There are many thorough tutorials about setting up key pairs , for example here.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .