Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

History:

My PC was configured with two drives: an 80G on IDE 0 Primary that was running Win2K, and a 320G on IDE 0 Secondary that was running Linux (Ubuntu). I decided to pull the 80Gb drive out of the system, so dd'd the entire 80 G drive (/dev/sda) onto the 320 (/dev/sdb) -- this included the MBR and partition table. Then I pulled the drive, plugged the 320 into IDE 0 Primary, and rebooted. The Windows partition worked at this point.

Then I installed Ubuntu into the remaining space on the 320. It works. However, when I try to boot into Windows, I get a BSOD with the following message:

*** STOP: 0x0000007B (0x89055030,0xC000014F,0x00000000,0x00000000)
INACCESSILE_BOOT_DEVICE

Before the BSOD I see the Win2K splash screen, and it claims to be "starting windows" for a couple of seconds -- so it appears that the first stage boot loader is working as expected. Ditto when I try booting in Safe Mode.

After reading the Microsoft KB article, I booted into the recovery console and tried running chkdsk /r. It refused to run, claiming that the drive was corrupted (sorry, didn't write down the exact error message).

However, I can mount the drive from Linux, and access all files. And for what it's worth, I can scan the drive using the Linux "Disk Utility" (this is Ubuntu, the menus don't show real program names), it claims the drive to be clean.

The KB article mentioned that boot.ini could be the problem, so here it is:

timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows 2000 Professional" /fastdetect

Any pointers on what to do next?

share|improve this question
    
Are you saying that you put the partition table from an 80GB drive onto a 320GB drive? –  bryan May 14 '10 at 15:31
    
@bryan - yes, however the Linux install rewrites the partition table. I did the same thing when converting my laptop (WinXP) to dual-boot on a larger drive, and didn't have any problems. –  kdgregory May 16 '10 at 12:47
    
Sounds like the kind of thing that can easily go wrong. –  bryan May 20 '10 at 18:27
    
From the recovery console, try running FIXBOOT. If that doesn't work, try FIXMBR then reinstall GRUB. –  TuxRug Sep 29 '10 at 15:57
add comment

1 Answer

I've been able to recover from similar post-linux install boot issues using systemrescuecd

Its sfdisk and grub tools are particularly relevant.

share|improve this answer
    
Sorry for not responding; I haven't had much time over the past few months (or next few, for that matter) to investigate the problem. Will let you know if that changes. –  kdgregory Dec 1 '10 at 0:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.