Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
  • I plugged in an external monitor.
  • All resolutions match perfectly.
  • MacBookPro LCD is closed.
  • After restarting Xcode editor fonts look very bad. Only in Xcode.
  • When I restart the mac and DON'T use an external monitor, fonts look all right again.
  • When I attach the monitor and close the LCD of the MacBookPro, fonts look nice.
  • Then I close Xcode and reopen it: Fonts suck.
  • Only way to get fonts look good is to disconnect external monitor and reboot, then reconnect external monitor, close LCD, wait, hit any key and let the external monitor be the only one. Fonts look nice - until I restart Xcode. I think it happens any time Xcode is launched with external monitor attached and ugly fonts survive until reboot. Unplugging external monitor and restarting Xcode doesn't help.

It seems like Xcode isn't antialiasing them properly after something happens.

Is there a fix for this problem?

EDIT: After trying a few more times, it seems it is possible to get fonts to look nice by disconnecting external monitor and reopening xcode.

Here are some little snapshots:

GOOD FONT:

alt text

UGLY FONT:

alt text

You can see how dirty the ugly font looks. It's very hard to read and hurts in the eyes. Believe me. It sucks. Sometimes the little "i" are almost invisible.

I make use of the very eye-friendly Dusk style of Xcode (go to preferences and choose that, if you haven't already. A real pleasure for your eyes)

share|improve this question

migrated from stackoverflow.com May 14 '10 at 13:36

This question came from our site for professional and enthusiast programmers.

2  
Sounds like an apple bug. –  user35583 May 12 '10 at 20:51
    
If you leave it open, does it still happen? –  FrustratedWithFormsDesigner May 12 '10 at 20:52
    
havent tried yet, but will report here what happens then... I observed the last time that it happend exactly right after restarting xcode. –  Anonymous May 12 '10 at 21:01
add comment

2 Answers 2

I am assuming you are using Snow Leopard. Try this from a terminal

defaults -currentHost write -globalDomain AppleFontSmoothing -int 3

and then restart XCode. Changing the 3 at the end will control how much anti-aliasing happens on the fonts and may range from 0-3 I believe. 0 being off, 1 being light anti-aliasing and 3 being heavy anti-aliasing. The OS should also remember this setting for your monitor so you should only have to change it once.

This is a bug in Snow Leopard. This could be changed in system preferences prior to 10.6 but now 10.6 tries to figure out the best setting for your monitor on its own and does not get it right most of the time.

share|improve this answer
    
ineresting. from where do you have that info? and what's the dafault, in case I screw up all my fonts with this? –  Anonymous May 13 '10 at 10:47
    
I had the same problem after upgrading to Snow Leopard. It was really bugging me so I did some googling. I think I found the info at www.macosxhints.com –  Brad S May 13 '10 at 13:22
    
You can run 'defaults delete -g AppleFontSmoothing' to return to the default if you want. –  Nicholas Riley May 13 '10 at 15:19
    
@Brad: Thanks, I just added an external monitor to my aging MBP got bit by this problem. I thought it was a problem with my MBP hardware trying to drive a high-res external monitor, but it seems that this mostly solved the issue. Have people filed a bug for this? Is there an active radar issue we should all get behind (I think we can vote for them, right?) Thanks again! –  Steve Lianoglou Jul 8 '10 at 2:25
add comment

The "ugly font" is non-subpixel antialiasing; the "good font" is subpixel antialiasing (note the colored fringes). I doubt this has anything to do with Xcode specifically. Just pick a font smoothing style from System Preferences > Appearance and don't let it be set to "Automatic".

If you notice, Automatic is "best for main display"; there's no way to get different AA styles on your different displays. These days, this is mostly a relic from the time when people had one LCD and one CRT display. I would suggest filing a bug, though.

share|improve this answer
    
In SysPref > Appearance there are only two settings: "Activate LCD-Antialiasig if available" and "Don't antialias if font is [4] or smaller". 4 is the smalles possible value. I have russian mac. Tried to translate it. –  Anonymous May 13 '10 at 10:44
    
See Brad S's response - the manual controls (which I describe) were removed in Snow Leopard but you can still adjust them with defaults. I happened to be writing from a Leopard machine and had forgotten. –  Nicholas Riley May 13 '10 at 15:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.