Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Windows XP in VirtualBox and basic operating system is Ubuntu. In Windows XP, when I put any pendrive, it doesn't read that. How can I fix this problem so that the pendrive can also be read in Windows XP? Any command?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Enable the USB controller in the virtual machine properties.

share|improve this answer
    
+1 Common oversight –  Dave M May 14 '10 at 14:39

A virtual machine is just that, a virtual machine. It doesn't see your USB ports, it sees virtual USB ports. If your host allows it, you can enable USB passthrough to expose the USB pen drive to the virtual machine.

share|improve this answer
    
thank you for suggestion but you didn't tell me how to enable virual usb ports –  Omkant May 20 '10 at 9:15
    
The virtual USB ports are probably enabled, just not mapped to any real ports. The following article says USB redirection is not available in the free Virtualbox release. howtoforge.com/… –  ta.speot.is May 20 '10 at 10:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.