Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to have a Maxtor Shared Storage II network drive; it broke down long ago already. (Later I tried to recover some data from it, and partially succeeded, but haven't yet fully documented it on that question.)

Anyway, I just noticed there are still some lingering bits remaining of the (thoroughly crappy) software that came with the Maxtor device: a background process called "MaxBack Engine".

alt text

I googled around a bit and found something related but not very useful:

Under /Applications I found "Maxtor" which I used to use for controlling the drive, and showed it some "rm -rf". Before deleting, I noted that the bundle did contain "MaxBack" under Content/Resources.

But still, after reboot, the "MaxBack Engine" process is back. I did notice though that it only appears when logging in with my usual user account; with another account it wasn't launched.

So, dear Mac gurus, what could I do about this pest? I guess I could fall back to some Unix hackery and write a cronjob that kills any process with that name, but obviously it'd be nicer to be able to clean up from my computer everything left behind by Maxtor's piece of software.

share|improve this question

While that was a pretty easy case, anytime you can't find a self-healing bit of software, this usually will:

share|improve this answer
Thanks, good to know about Consultant’s Canary. I just tried it out, and it seems like a really useful tool! – Jonik May 17 '10 at 22:45

If you can't find out how to remove it, chmod it 000.

share|improve this answer
In my case there was no problem deleting the culprit after I found it - thanks anyway! – Jonik May 14 '10 at 17:59
up vote 0 down vote accepted

Oh well, it wasn't that difficult after all.

I looked under System Prefs -> Accounts -> Login Items, and "MaxBack Engine" was there on the list, along with the possibility to disable it from starting upon login.

alt text

The tooltip additionally told me the application is at:

/Library/Application Support/Maxtor/MaxBack

So, I deleted (permanently) the whole Maxtor directory (it contained another file called "MBHelperTool" along with "MaxBack"), and verified (by reboot & login) that it indeed is gone for good now!

share|improve this answer
Yet another case of me basically using SU as a "rubber duck", but oh well :) – Jonik May 14 '10 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .