Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After update and reboot I get 'user is not in the sudoers file. This incident will be reported.' when trying to call sudo. The problem is that I don't have a GRUB with revovery option. I try to boot from live cd but I'm not able to access the system partition, only the partition with grub. Can I somehow enable the recovery mode in GRUB? Or boot throw the live CD from first hard drive with some option for that?

share|improve this question
    
do you get an error when you try to access the system partition? –  bryan May 14 '10 at 18:12
    
if you can get to your boot partition, you can examine /boot/grub/grub.cfg to see what root partition it loads. post one of the boot entries from that, and the output of fdisk -l (while booted into the LiveCD) so we can help you better. –  quack quixote May 14 '10 at 18:37

3 Answers 3

Ubuntu's "recovery" is just another name for "single user mode". You can access it by adding the option single to the kernel line in grub. (It used to be the e key; I don't know how to do it in grub2.)

share|improve this answer
    
I tried the single but it does not work. –  martin.malek May 14 '10 at 18:35
3  
@martin.malek Please explain what happens, not just 'it does not work'. Does it ask for a password, does it give an error, does it boot normally as if you didn't enter 'single', etc etc –  davr May 14 '10 at 18:57

If you're not seeing a Grub menu at boot time, it's probably hidden. Hold down Shift when booting to unhide the boot menu. Your recovery options should be there.

This assumes (1) you're using Grub as your bootloader, and not Win7's boot manager; and (2) you've left Grub in a default configuration. If you've tweaked your Grub menu, for example to remove the recovery options, this doesn't apply.

share|improve this answer
up vote 0 down vote accepted

Ok, solved. When I was not able to run it in single mode, this helped: http://www.cyberciti.biz/faq/howto-boot-ubuntu-linux-rescue-mode/

share|improve this answer
    
If this solved your problems, please accept it. –  AndrejaKo Sep 5 '10 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.