Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When X.org boots up, Synaptics touchpad works well. But when I remove the module it falls back to /dev/input/mice and don't use normal driver even when touchpad is available again.

Xorg.0.log:
...
(II) XINPUT: Adding extended input device "Synaptics Touchpad" (type: TOUCHPAD)
(--) Synaptics Touchpad: touchpad found

# { rmmod psmouse && echo mem > /sys/power/state && modprobe psmouse; }

(WW) : No Device specified, looking for one...
(II) : Setting Device option to "/dev/input/mice"
...

How to tell X.org to try it's InputDevice again (without restarting X server)?

P.S. rmmod psmouse is needed to prevent crashing of Acer Extensa 5220 when resuming from suspend-to-ram.

Update: Found answer myself: Doing xinput set-int-prop "Synaptics Touchpad" "Device Enabled" 8 1 after reloading the kernel module reloads touchpad. Now suspend-to-ram works OK.

share|improve this question
    
Thank you for providing the answer here, even if you found by yourself. Hopefully this will help other persons with this issue, in the future. – Gnoupi May 14 '10 at 21:19
    
@Gnoupi I've just discussed this: meta.stackexchange.com/questions/49922 – Vi. May 14 '10 at 21:25
    
Thanks a lot! Year after it still helps! (Ubuntu 15.04) – Vadym S. Khondar May 11 '15 at 20:27
up vote 7 down vote accepted

xinput set-int-prop "Synaptics Touchpad" "Device Enabled" 8 1 restores Touchpad extensions.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .