Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a linksys router WRT54G2 connected to a cable broadband. Just last week, everything was working perfectly - I would be able to connect my laptop to the internet using WiFi.

However, starting last week, I suddenly lost my internet connection. At first I thought something was wrong with my ISP. However, when I tried connecting the cable directly to my laptop, I found out that there was no problem with the internet connection after all.

It appears that it is only my router that cannot get IP address. I have already tried cloning my MAC address and reconfiguring my router using the setup CD, but nothing worked.

What could be the problem here? Thank you.

Regards, Erwin

share|improve this question

migrated from serverfault.com May 15 '10 at 6:33

This question came from our site for system and network administrators.

    
What's the model of Cable Modem? If it's a DOCSIS 1.1 modem it might have been phased out; I've seen this a lot lately. – Chris S May 15 '10 at 2:28
    
Honestly, I'm not sure what to call this cable, but this one was supplied to me by my ISP. The cable is connected to a canopy on my roof. The model is PSA15R-295 (Motorola). Was this info helpful? – Anonymous May 15 '10 at 3:03
    
@Chris Since OP can get an IP address on the laptop, we know it's not an issue with the modem. – NReilingh Feb 11 '11 at 3:37

Update the firmware. LinkSys firmware is made from pixie dust. Tinkerbell might have escaped so you need a fresh sprite to take her place.

Seriously, any firmware that starts with L and ends with inkSys should not be trusted. Update the firmware to the latest version. Consider switching to DD-WRT. I've had spontaneous failures like this with the LinkSys devices I've had the displeasure of managing and often a reboot or firmware upgrade "fixed" it.

It's the closest thing to voodoo I've ever encountered in this profession.

EDIT: Sounds stupid, but have you rebooted the thing via a power cycle?

share|improve this answer
1  
i've also seen both Linksys and Netgear routers simply die for no apparent reason, even with 3rd-party firmware. maybe power spikes fried them, i don't know. but yeah, if you can still flash firmware onto the device, reflashing with DD-WRT or OpenWRT or Tomato is a good thing to try. – quack quixote May 15 '10 at 6:41
    
+1 "LinkSys firmware is made from pixie dust. Tinkerbell might have escaped so you need a fresh sprite to take her place" for AWESOME. – goblinbox Dec 25 '10 at 4:09
    
In addition to powercycling the router and ensuring it's configured properly to get a DHCP ID from the modem, you might need to powercycle the modem after the router is connected. In the past, I've seen situations where the modem/gateway will only distribute IPs to the MAC addresses that were plugged into it when it booted. – NReilingh Feb 11 '11 at 3:40

After trying the latest firmware, you may need to consider that your router has passed on to the big bit bucket in the heavens.

share|improve this answer

Some ISP modems have a built in DHCP server (i.e. it gives IP's). Therefore your Linksys router should become a switch. Try disabling DHCP on your Linksys. If you can't get to it, hard-reset it and hook it up directly to a computer.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .