Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After transferring all my files onto a new machine, all files that were once LaTeX files (having the texnic center "T" icon) are now TeX files (having the TeX works icon --I don't remember installing that one!). But....the files are associated with the technic center! In other words, the files open with the texnic center, yet the "type of file" is "tex document".

I'm using the same miktex distrubution and texnicCenter (both for windows xp) as on the old machine. Again, I don't know how/where I got this texworks on the new machine--assuming it came with windows.

A question: Could these tex associations cause me any new surprises, anything unexpected? Like certain packages not working, etc? Because I can't have that!! Should I not fix it if it ain't broken!?

For instance, one particular file yesterday would not produce any pdf output after compiling...after trying many things (other files compiled as they should have), I got to thinking to try it without the setspace for doublespacing!! And it worked. I have no idea why. Anyway....

Real question: How to revert to LaTeX file associations??

Rhetorical question: Would this question have better luck in ctan or stackoverflow? I guess I'll find out!

Thank you wholeheartedly!

share|improve this question
1  
Strictly speaking, LaTeX is a TeX application in the same way that XHTML is an XML application. –  Ignacio Vazquez-Abrams May 15 '10 at 12:02

2 Answers 2

up vote 4 down vote accepted
  1. Texworks comes installed with Miktex.
  2. What an icon looks like is irrelevant as long as it is associated with the correct program.
  3. As someone else pointed out, LaTeX is a TeX application.
share|improve this answer
    
thanks for the reply. I'll give your answer the check mark, but I still don't know why the new computer recognizes the files as TeX files, while on the old computer, as LaTeX files. Unless I am completely forgetting how I installed miktex on the old machine, I installed the same distribution from the same site within 6 months of each install... Thanks again. –  andrz_001 May 24 '10 at 18:11
    
If it is exactly the same distribution, then I'm not sure what happened. I think in Windows XP there is a way to manually change the icon through "Folder Options". –  Peon May 24 '10 at 22:07

Your files in the old and new computer were .tex files. Maybe your computer was configured not to show the file extension (the .tex), but regardless they were still .tex files (I used TeXnicCenter until 2 weeks ago for LaTeX, and all my files were .tex). A computer (or should I say a PC?) will have a "preferred" software to open files. When you installed TeXnicCenter in the old computer and opened/created your first .tex file, either you were asked whether you wanted to always open files of that type with TeXnicCenter or it did that automatically. From that moment whenever you double-clicked on a .tex file it would open with TeXnicCenter, the icons on .tex files were the TeXnicCenter icon, and all files of that type were associated with that software.

When you got a new computer and installed MixTex, TexWorks was installed with it (you can check in the MixTex website, the distribution comes with TexWorks by default). So your .tex files on that computer were associated with TexWorks and would carry the icon of that software. That doesn't mean your files changed, or the type of file changed.

You can easily change the program associated with your .tex files by going to a .tex file, right-click, choose "open with" then it is important that you click on "choose program", then even if you see TeXnicCenter on the list, choose "other". A new window will open, and there you need to choose TeXnicCenter and make sure you check the box "Always use this program to open files of this type".

Your .tex files will now have the TeXnicCenter icon :)

This post might be useful, though I would make sure that on step 5 you don't choose TeXnicCenter, and click on "other" so that the new window with the option "Always use this program to open files of this type" appears.

Edit: OK, so this won't change your icon. The solution will depend on which version of windows you are using. For Windows Vista and Windows 7 have a look at this. For Windows XP, I think the following will do:

  1. Go to your control panel

  2. Choose "folder options"

  3. In the tab "file types" find the extension .tex, then choose advanced (and you might want to do the same for other file types associated with latex)

alt text

I don't have administrator rights, so I don't know what exactly is there, but I believe you might be able to find what you want!

share|improve this answer
    
Thanks for the reply. I've gotten over it at this point in time, as it doesn't interfere with anything I'm doing. I suppose I got a little nervous at first thinking it was the reason why some packages weren't loading (I figured that out). Then it was just bugging me for a while. Anyways...the ''problem'' still persists. On the old PC, the type looks like imgur.com/DMBnB.jpg while on the new PC they are still TeX files, despite having reinstalled MikTeX. Also, even though the files are associated with texnicCenter, and open with it, the file icon remains the texworks icon. oh well...:) –  andrz_001 Jun 2 '10 at 15:46
    
I updated the answer, I hope it helps :) –  Vivi Jun 5 '10 at 4:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.