Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have got the cuda driver, toolkit and sdk installed in Ubuntu 10.04. I'm using nVidia Geforce 8600 GT card. Official website says my card is CUDA supported. But on running the deviceQuery that comes with the cuda sdk, I'm getting the following output.

./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

There is no device supporting CUDA

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 134566327, CUDA Runtime Version = 0.0, NumDevs = 0


PASSED

Press <Enter> to Quit...

Moreover, while booting, I'm getting the following error. Ubuntu is running in low-graphics mode

The following error was encountered. You may need to update your configuration to solve this.

(EE) NVIDIA: Failed to load the NVIDIA kernel module.
Please check you
(EE) NVIDIA:   system's kernel log for additional error messages.
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

But, when I restart X, it boots perfectly.

And, glxinfo gives the following output.

name of display: :1.0
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
3 GLXFBConfigs:
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Segmentation fault

So, is GeForce 8600GT actually not CUDA supported, or is the problem with something else? Thanks.

share|improve this question
    
Have you run nvidia-settings to ensure that your driver was installed? What version of the driver did you install (195.36.24?) and what version of CUDA (3.0?)? –  fideli May 15 '10 at 16:08
    
I'm using 195.36.15 driver and CUDA 3.0. Running nvidia-settings produced "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server." I did just that, but the problem persists. I have also edited my question to add more info on the problem. Any help would be appreciated. Thanks –  viswanathgs May 15 '10 at 16:28
add comment

1 Answer

up vote 0 down vote accepted

Well. There is a good way to install the nvidia driver correctly and the avoid problems later. Here is a great howto, step-by-step, easy-to-use.

But let me correct it out, regarding the 10.04 release !
First of all (before steps), download the "dkms" pack from the bottom of the post on the linked page, and the nvidia driver from nvidia.com into your home directory.
Step1, remove the drivers. Fix the "180" to "190" or "195" , don't sure how Ubuntu calls it at the minutre.
At step 2, edit /etc/blacklist.d/blacklist.conf . Add 2 new entries to the end:
blacklist nv
blacklist nouveau

Then do a reboot, at the boot menu, select recovery mode. Go with the "root mode with networking" (or what, its at the bottom, you will be able to identify it, don't worry about the instructions. :))

When it boots, type your root password. Then type: init 3 . Login again (yay).

Now, install the driver with sudo sh ./NV* . There will be an error about "distributor provided.." don't care about it, just agree, yes yes (more, grep, fsck :)).

After it finishes, do a sudo nvidia-xconfig . THEN, do the sudo sh ./installdkms* part. After it finishes, you are done, reboot.


Yeah I'm aware of the howto and how its 'harder' than the "install restricted modules". However, a lot of people noticed issues , anomalies with the default driver. This way you will get the NVidia binary driver, more recent than the one Ubuntu ships, and it won't be a problem during kernel upgrades. Also, you can upgrade the driver by hand whenever you want. If you get stuck, comment, ask. (Check which part seems to be hard , check if you can find that blacklist and such before you dive in.)


And yeah, after this, we'll continue with the CUDA stuff. :)

share|improve this answer
    
In my case, I had to run sudo sh ./NV* -k $(uname -r) in order for it to properly install kernel modules and not hang at that part of the installation. –  fideli May 15 '10 at 17:22
    
That can happen if you dont run the latest kernel installed. In that case, try regenerating your grub config (sudo update-grub) , do a reboot, fire up the latest kernel and try reinstalling. –  Shiki May 15 '10 at 17:27
    
Thanks. I followed the steps and installed the devdriver 195.36.15. But after booting, my screen resolution has gone really low, and in nvidia-settings X server display configuration, I can't find any resolution higher than 640x480. And, I have not yet proceeded with the cuda toolkit installation. –  viswanathgs May 15 '10 at 17:50
    
Installed the toolkit and the SDK. The code samples work perfectly, thanks a lot for your help. Now the only problem is the resolution, which does not go above 640x480. Any help regarding that is much appreciated. –  viswanathgs May 15 '10 at 18:13
    
Okay. Did you do the sudo nvidia-xconfig part? If yes, type sudo nvidia-settings into a terminal and set it higher. It HAVE to go higher if you have a correctly working NVidia driver. –  Shiki May 16 '10 at 7:51
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.