Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't install any program and got error "Your system administrator has set policies to prevent this installation". How can I solve it?

share|improve this question

closed as not a real question by DragonLord, ChrisF, HackToHell, BBlake, Synetech Nov 1 '12 at 13:36

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Are you logged on as a user with administrative rights? –  Nifle May 16 '10 at 13:02
    
These restrictions are defined by what's called Group Policy, where administrators can configure a wide variety of restrictions and system settings to suit various needs for use in business environments, etc. Note that the Group Policy Editor, gpedit.msc, is only available on Windows XP Professional; Windows Vista Business, Enterprise, and Ultimate; Windows 7 Professional, Enterprise, and Ulitmate; and Windows 8 Pro and Enterprise editions. The consumer-oriented versions of Windows do not have this feature. –  DragonLord Nov 1 '12 at 5:20
    
This should be reopened as a real question. The correct answer is identified and accepted. –  aqua Mar 15 '13 at 18:36

4 Answers 4

If you are in a business, government, educational, or other environment that is not your own personal home network, that sort of message generally indicates that the system administrator does not want unknown and unapproved software installed on computer systems for which they have responsibility. This restriction could be in place for a variety of reasons (national security restrictions; health, financial, or other privacy concerns; software licensing restrictions; or simply not wanting to support random software installed by users).

Your best course of action if the computer and network are not legally yours is to contact the system administrator for assistance. They may be willing to grant an exception to the policy if you can make the case that you really do need the software.

share|improve this answer
3  
+1 for not supporting random software –  Holocryptic May 16 '10 at 16:47
2  
+1 also for that. If the computer isn't yours, don't touch!! As someone that in the past has had to clean up the messes that installing unauthorized software creates for sysadmins, I can't say it enough. If you want to install something for work, talk with the admins about the app you want to use. Otherwise, go home and install it on your personal computer. If this is your personal computer and you don't have rights to it, that's a whole other issue. –  BBlake May 16 '10 at 17:29
    
That's my personal computer. I'm sure my user account have administrator right. I download and run some files from online. After that i got this error and i think my pc is Virus effect. I follow the instruction from systemadministratorhassetpoliciestopreventthisinstallation.com . But that can't fix my problem. –  LoRdiE May 18 '10 at 10:39
    
If it is your personal computer then it is possible that you have a virus or other malware. If you can't find out what your are infected with then wiping and reinstalling the OS may be your only course of action. –  Mike Chess May 18 '10 at 14:13
    
Edit your question to indicate that it's your own computer and why you suspect a virus. –  CarlF Nov 9 '10 at 19:46
up vote 5 down vote accepted

The solution is to change the DisableMSI value in the registry: under the key HKLM\Software\Policies\Microsoft\Windows\Installer, set the value of DisableMSI to 0.

share|improve this answer

Use a portable version of the application or contact the administrator.

share|improve this answer
    
+1 for portable suggestion, however this sometimes is infeasible. –  aqua Mar 15 '13 at 18:39

Microsoft must have disabled MSI installation for a reason. There is probably some kind of security vulnerability in it. It doesn't make sense to change the settings of your computer to permanently allow all MSI installations. The correct thing to do is not change your registry, it is to go to Start->Programs->Accessories and right click on Command and choose "Run as Administrator" then navigate to the folder where the installer file is and run it. This will bypass this message for this installation only.

share|improve this answer
    
This problem is more insidious than I thought, and the method I describe above will not work under certain scenarios. For example, if you want to uninstall an MSI installed program from Add Remove Programs, you can't. –  RyanTM Nov 17 '10 at 22:57
    
Your method doesn't work. –  aqua Mar 15 '13 at 18:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.