Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know Mozilla thinks it's a bug that IE shows ALT text even after the image has loaded; while users think it's a bug that Firefox doesn't work exactly like IE. This disagreement is irrelevant to my question:

How can I make my Firefox show the ALT tooltip when I hover the mouse over an image?
Obviously XKCD is a bit tame without this essential functionality.

I've tried the Firefox plugin Popup ALT Attribute but it doesn't work; after restarting the browser and hovering over an image with an ALT text, no tooltip appears. I reproduced this on several computers with several (Windows) OS versions.

share|improve this question
    
I'm not seeing the problem... xkcd has its tooltip jokes - correctly - in the title attribute, which Firefox displays. The alt attribute for xkcd images is simply the title of the comic. (Of course, I can see why you'd want to use it for other sites, but I don't think xkcd is a good example of this issue) – Corey May 16 '10 at 17:52
    
Thanks for the answers and comments so far! Still, even though you note XKCD uses TITLE tags and not ALT tags, this doesn't work for me using Firefox363 on a freshly installed Win7. How can this be? What am I doing wrong? – Torben Gundtofte-Bruun May 16 '10 at 18:36
1  
There may be an extension on all of these different Firefox installations that is causing this problem (Google toolbar made a similar problem for some users: support.mozilla.com/…). Have you tried hovering over xkcd with a clean Firefox installation without plugins? – Trey Hunner May 17 '10 at 7:27
    
I've disabled all extensions and restarted; still no tooltip appears. I don't have a lot anyway: AdblockPlus, AutoCopy, CopyPlainText, DownloadStatusbar, MinimalistGmail, SearchPreview, Sxipper, Xmarks. – Torben Gundtofte-Bruun May 18 '10 at 17:02
    
@torbengb Have you checked that browser.chrome.toolbar_tips in about:config is set to true? – sblair May 30 '10 at 16:56
up vote 7 down vote accepted

The alt text has a different purpose from the title text; Firefox (at least, in recent versions) does correctly display the title attribute value when the mouse hovers over an image (and it definitely works for xkcd).

Edit: in this case, browser.chrome.toolbar_tips in about:config needed to be set to true.

share|improve this answer
    
Yes, this fixed it! My Firefox had it set to false and toggling it back and forth confirmed this to be the culprit. – Torben Gundtofte-Bruun Aug 6 '10 at 9:35
    
Just a note: at least in Ubuntu, Firefox 11, you need to restart the browser. it was not immediately obvious to me... – brandizzi Apr 27 '12 at 13:54

I'm not sure what your issue is, if I hover over an image in FF it displays the title text.

I'm a regular XKCD reader, that's why I know.

share|improve this answer
1  
Not quite, Firefox displays the title text in the tooltip. – sblair May 16 '10 at 16:21
    
You're right, edited answer. – Josh K May 16 '10 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .