Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop PC with Fedora, Ubuntu and Windows installed and grub used for multibooting. But time in Fedora is always 5 hours behind. If I change the time in Fedora, then Windows and Ubuntu will be 5 hours ahead of the current time. I don't understand how to fix it.

Any ideas? All the timezone settings in Fedora, Ubuntu and Windows are the same.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You use UTC instead of localtime or vica versa (in Fedora that is).

Check /etc/sysconfig/clock for settings. (use sudo gedit /etc/sysconfig/clock)

Oh, there is a cute howto also: http://fadvisor.net/blog/2008/06/fedora-9-and-utclocaltime-time-problem/

share|improve this answer

I fixed this problem in Fedora 12 by choosing System | Administration | Date & Time | Time Zone, unticking 'System clock uses UTC' and then adjusting the time correctly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.