Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Fedora 10 with XFCE. Every time I open Gedit, it opens a instance on every workspace. The circle icon on my window border is selected (meaning, enabled on all workspaces). When I disable it to appear on one workspace, then close and restart(program), Gedit opens normal (current workspace). Question is: How to keep this current configuration? If I restart my system, and start up Gedit, it appears on all workspaces again.

share|improve this question
add comment

1 Answer

I'm sure you know this, but fedora 10 is outdated and no longer supported and you should probably migrate to something fresher, and probably this issue doesn't even exist there :)

Question: Does this happen when you launch it from a terminal too, or only from the entries provided by xfce? What version of xfce? Is it a pure xfce & xfwm setup or do you use it in combination with something else? (Can't post comments, forgive me!)

The name for this behaviour is sticky, might want to check the settings manager (window manager and related sections) for how it's set up.

If unable to find the cause, you could hack around it with wmctrl, see here using wmctrl -r gedit -b remove,sticky

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.