A couple of questions and points:
1/ Why are you trying to install vim-gtk? I'm running Ubuntu 8.04 rather than 8.10 but I notice that the Ubuntu "blessed" (see the icon to the left of it in Synaptic) version of gvim is vim-gnome, not vim-gtk. This may be different in 8.10.
2/ The error message seems pretty explicit. The version of vim-gtk you're trying to install requires 2.15.0 or greater version of libgtk2.0.0, the Ubuntu blessed version is 2.14.4-0ubuntu2, hence the dependency problem. I think if you want to run that vim-gtk, you'll need to suck down later versions of the dependencies (such as adding GTK itself as a repository if they're not available in the Ubuntu repositories).
3/ Point 2 is especially important if you're getting vim from somewhere other than the Ubuntu repositories. I say this because the online package explorer for Ibex says that vim-gtk 1:7.1.314-3ubuntu3.1 requires libgtk2.0.0 2.14.1 or better (rather than your stated 2.15.0). If you're using a non-Ubuntu repository, Ubuntu specifically states that testing is your responsibility. I personally don't use the non-Ubuntu repositories unless it's absolutely required, since you have to ensure that your dependencies are met, and that they don't break existing packages.