Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install GVim on Ubuntu 8.10, I get the following error message:

$sudo apt-get install vim-gtk


The following packages have unmet dependencies:
  vim-gtk: Depends: libgtk2.0-0 (>= 2.15.0) but 2.14.4-0ubuntu2 is to be installed
E: Broken packages

I installed all libgtk2.0-0 related packages in Synaptic Package Manager but the problem persists.

How can I resolve this problem?

share|improve this question

migrated from Jul 28 '09 at 4:40

This question came from our site for professional and enthusiast programmers.

And on a point related to the question, what do apt-cache policy vim-gtk and apt-cache policy libgtk2.0-0 show? – bdonlan Jul 27 '09 at 21:55

A couple of questions and points:

1/ Why are you trying to install vim-gtk? I'm running Ubuntu 8.04 rather than 8.10 but I notice that the Ubuntu "blessed" (see the icon to the left of it in Synaptic) version of gvim is vim-gnome, not vim-gtk. This may be different in 8.10.

2/ The error message seems pretty explicit. The version of vim-gtk you're trying to install requires 2.15.0 or greater version of libgtk2.0.0, the Ubuntu blessed version is 2.14.4-0ubuntu2, hence the dependency problem. I think if you want to run that vim-gtk, you'll need to suck down later versions of the dependencies (such as adding GTK itself as a repository if they're not available in the Ubuntu repositories).

3/ Point 2 is especially important if you're getting vim from somewhere other than the Ubuntu repositories. I say this because the online package explorer for Ibex says that vim-gtk 1:7.1.314-3ubuntu3.1 requires libgtk2.0.0 2.14.1 or better (rather than your stated 2.15.0). If you're using a non-Ubuntu repository, Ubuntu specifically states that testing is your responsibility. I personally don't use the non-Ubuntu repositories unless it's absolutely required, since you have to ensure that your dependencies are met, and that they don't break existing packages.

share|improve this answer
I have no special reason for using vim-gtk, so I tried installing vim-gnome, but this results in exactly the same error message as above. I can find libgtk2.14.4-0ubuntu2 neither with sudo apt get install -""- nor with synaptic packet manager(I'm now using ubuntu repos only but this should be there? – Zequj Mar 25 '09 at 16:35

You need to enable more package repositories (i think Universe will be sufficient). Here's official description:

share|improve this answer
I think the questioner already has Universe enabled since that's where vim-gtk resides. If it wasn't enabled, it wouldn't get to the dependency checking phase at all. – Pax Mar 2 '09 at 0:07

Have you tried going to Add/Remove programs in the main menu and installing Gvim from there? It will get the program from trusted repositories and might fill in dependency problems for you. It is just a easier frontend for the package manager. Other than that again ubuntuforums, they are great!

share|improve this answer

The following worked for me:

run this

sudo apt-get update 

and then run

sudo apt-get install vim-gnome 
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.