Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I find that when I type Chinese characters(encoded with utf-8) into VIM,I cannot see them at all while they do exist there.I can copy and paste them into other text editors and it seems everything is fine.How can I fix this problem?Thanks!

share|improve this question
up vote 5 down vote accepted

you are not using a font which contains the glyphs needed to display the characters you typed.

so, choose the right font via

:set guifont=*

or

:set guifontwide=*

which would pop up a font-selection-dialog. and once you have a working font make it permanent by putting

set guifont=YOURFONT

to your .gvimrc / .vimrc

share|improve this answer
    
Neither of these worked for me on Debian with VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Feb 10 2013 02:28:47). No font-selection-dialog appeared. – Mike Oct 8 '13 at 1:51
    
@Mike: guifont settings are for gvim. are you using console-vim? if so: consult the manual of your terminal-program (which is responsible for drawing glyphs). – akira Oct 8 '13 at 4:54
    
Ahh, didn't notice that little detail. – Mike Oct 8 '13 at 6:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .