Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I remember having this issue in the past with previous versions as well but recently it started here again. Whenever I click a link that links directly to a PNG image I get a download dialog; the browser won't display it on its own. Inline PNGs are fine, though.

ETA: It apparently only happens from PNG images linked from RSS feeds. Maybe it has always been so, I can't really say.

ETA2: IE 8 it is, as should be common sense but apparently it needs to be stated explicitly sigh.

Any ideas what causes this? It did work in the past.

Preemptive warning: I'm not looking for advice to change my browser; I'm looking for a solution to a specific problem with one piece of software. Just ignore the fact that it may have religious importance.

share|improve this question
    
You didn't even say what version of IE... –  Lohoris May 17 '10 at 9:03
    
Indeed. Did you try it with the latest IE9? –  Shiki May 17 '10 at 10:49
    
I think he should use Chrome. –  ta.speot.is May 17 '10 at 10:55
    
:D Doesn't make too much sense. Chrome is still under construction. When it will bring normal AdBlock (preemptive functions, not just adblock), etc. Won't list all the issues. Firefox would be a good choice because the market share forces web devs to support it. :) –  Shiki May 17 '10 at 11:05
    
I also think Safari or Opera will solve these problems. –  ta.speot.is May 17 '10 at 11:06

1 Answer 1

Preemptive warning: I'm not looking for advice to change my browser; I'm looking for a solu-

Chrome.

It apparently only happens from PNG images linked from RSS feeds. Maybe it has always been so, I can't really say.

As far as some things to get you started troubleshooting this, you may want to look at MIME Sniffing in Internet Explorer. It will try and infer the type of resource being requested, rather than look at the MIME type.

There is also a miscellaneous option under "Security Zones" called Open files based on content, not file extension, which invokes the above behaviour.

There are some extended controls for it in the registry, down the bottom of this article.

share|improve this answer
    
Great solution. :D –  Shiki May 17 '10 at 10:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.