Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Dell Inspiron 1420 - 32 Bit - Windows Vista, since 2.5 years. I'm facing a strange problem with my CD/DVD-drive. I cannot run/play a CD/DVD which I get burned from my friends. But when I insert Genuine CD, I'm able to play/run it. And when I try to install my Vista package which I got with my notebook, the CD/DVD gets loaded. If I insert a CD/DVD which I get from my friend, CD doesn't get loaded and the system gets hanged. But all these CDs/DVDs work on other systems. I've tested it on many of my friends PCs.

So, now I'm able to run only genuine CDs & a few genuine DVDs.

My Experience/Experiments:

  • I tried to install Windows Vista using Genuine DVD - It worked
  • I tried to install Ubuntu which I got from shipped from Canonical Ltd. - It worked
  • I tried to install OpenSUSE .iso file burned to a DVD in my friend's PC - It didn't work for me (But working perfectly fine in my friends PCs(Tested in 4 other PCs)
  • Tried to play a DVD containing movies, burned in my friend's PC - It didn't work for me (But working perfectly fine in my friends PCs

Any help/suggestions would be appreciated. Thanks.

share|improve this question
2  
BURN ME! Firmware update? (Grab it from Dell with BIOS updates also) :P (Fixed my problem ...) –  Shiki May 17 '10 at 10:37
    
I didn't get you dude. Do you want me to download BIOS updates from Dell website?? Anything else? Thanks. –  Rahul May 17 '10 at 10:56
    
Yes I want you to do that. Also , check for CD/DVD rom (BIOS + normal) updates. There are drivers on the manufacturer's website usually. (Guess Dell got some also) –  Shiki May 17 '10 at 13:15

2 Answers 2

It is likely your player does not support the standard your friend is using (DVD+R vs. DVD-R).

share|improve this answer
    
Thanks for your reply, but everything is almost same. Probably I've to install some new drivers as mentioned by @Shiki in his comment. –  Rahul May 17 '10 at 12:22

it look like you got a picky CD/DVD-drive. There is many thing that could affect the ability of a drive to read a media. It goes form the speed of the burning, the type of media, or even the brand of media.

Like Shiki said, you could also try to update the Firmware of the drive. (the Firmware is like the bios of the drive itself.) You should be able to get it form Dell.

It could also be a hardware problem, like a dirty lens (specially if you smoke) or a defective drive.

You could also try to download a free Cd rom image like http://www.ultimatebootcd.com/ and try to burn it yourself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.