Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This works in Bash (parse_git_branch is a defined function)

export PS1="\$(parse_git_branch)"

but I cannot figure out the equivalent in zsh.

Note: If I do

PROMPT="$(parse_git_branch)"

it seems to work, but in fact it's running the command when I set the prompt, which is not the point.

share|improve this question
add comment

3 Answers

up vote 10 down vote accepted

you have to

setopt PROMPT_SUBST

in your .zshrc, man zshall explains it in the PROMPT EXPANSION section:

If the PROMPT_SUBST option is set, the prompt string is first subjected to parameter expansion, command substitution and arithmetic expansion.

share|improve this answer
add comment

Actually your problem was not just setting PROMPT_SUBST: you use double quotes in your script forcing the evaluation of the function when you set the PROMPT variables. You only want evaluation when the prompt is computed that is you must use single quotes.

share|improve this answer
add comment

As akira says, you have to use prompt subst. This is my early code (still working on it):

setopt PROMPT_SUBST
PROMPT='$(parse_git_branch)'

or better

setopt PROMPT_SUBST
PROMPT='[$PR_MAGENTA%n$PR_NO_COLOR@$PR_GREEN%U%m%u$PR_NO_COLOR:$PR_RED%2c$PR_NO_COLOR]$(parse_git_branch) %(!.#.$)'
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.