Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had this problem for a while now. My linux server is set to wake-on-lan but occasionally it halts at Grubs "Starting Up..." and goes no further. This is not due to additional hardware being attached such as a flash drive or anything as I never plug anything into it. It may boot perfectly 40 times in a row and then hit this issue. Sometimes it gets the issue a couple of times in quick succession and doesn't happen for ages again. I'm not sure how to diagnose it since it doesn't seem to be reproducible. Any help much appreciated.

Thanks

Edit:

Well, it's been a while since I've had one of these, mainly because my server has been on for a long time. However, I've captured an instance and I have the dmesg file but due to its size I can't just paste it below. Looking at the file, there's a period between 3.164 seconds and 14.13 seconds where there are no messages. I'll look at hosting the file somewhere but in the meantime, are there any messages in particular that I should look for?

share|improve this question

1 Answer 1

You don't say which version of grub or Ubuntu, but if it's applicable, I'd suggest adding a bit of a rootdelay to the kernel line in /boot/grub/menu.lst and see if that helps.

kernel     vmlinuz ... rootdelay=90

You might try a smaller value for the number of seconds.

share|improve this answer
    
Thanks Dennis, I'm now on Ubuntu 10.04 but was on Jaunty and it happened with that version too. As for Grub, that's version 1.98-1ubuntu6. What is it you think is happening that would be averted with a delay? –  conorgriffin May 17 '10 at 20:41
    
@Griffo: On one older system I have, one of the drives doesn't get detected unless I have that delay. I don't know whether it'll help you but it's worth a try. –  Dennis Williamson May 17 '10 at 20:48
    
OK, I'll give it a shot thanks. Just odd that it is intermittent, I'd have thought if it needed a delay, it would always need it. –  conorgriffin May 17 '10 at 20:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.