Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ubuntu 10.04

Hi guys. I'm not sure why but quite recently, my ubuntu desktop started bringing up the command prompt login screen after booting. I want GDM to start up by default.

I can manually bring up GDM by typing:

sudo service gdm start


sudo /usr/sbin/gdm

but I want something more permanent.

The contents of /etc/X11/default-display-manager point to /usr/sbin/gdm

The chkconfig status for GDM shows that it's off on all run levels... could that be it? I tried running:

sudo chkconfig --add gdm 

and just got errors...

Any ideas? How can I get GDM to automatically come up again? Any/all help is appreciated!


Update 1: I've tried running dpkg-reconfigure gdm but nothing seems to happen and it just returns me to the prompt (no errors).

Update 2: If I press CTRL-ALT-F7 at the command login prompt, I see what appears to be the linux boot-up console output. I noticed the following lines at the bottom:

** (gdm-binary:1256): WARNING *: Failed to acquire org.gnome.DisplayManager * (gdm-binary:1256): WARNING **: Could not acquire name; bailing out.

I think this is the cause of the problem but I'm not sure what it means. I'm going to try uninstalling and reinstalling GDM.

Update 3: I uninstalled gdm (apt-get remove gdm) and reinstalled it (apt-get install gdm). That seemed to address the errors in update #2 but it still won't start automatically on it's own. As a temporary workaround, I also added /usr/sbin/gdm & to /etc/rc.local and that seemed to start it... but I dunno... seems a bit "unclean".

I don't know if its helpful or not, but I have a tri-monitor system (one nVidia 9400 and one integrated nvidia mobo video) -- all monitors are on a separate xscreen. There are no issues with displays when I manually start GDM.

share|improve this question
What errors does sudo chkconfig --add gdm give? – Jawa May 18 '10 at 5:01
@Jawa it goes by to fast but the bottom part says "The script you are attempting to invoke has been converted to an Upstart job, but lsb-header is not supported for Upstart jobs" – Mike B May 18 '10 at 5:08
@Mikey Even my system (Ubuntu 10.04) doesn't have gdm enabled for any of the runlevels, but it still comes up automatically... – kartikmohta May 18 '10 at 5:10
Thanks @kartikmohta I guess I'm looking in the wrong place then... where else should I check for why it's not automatically starting? – Mike B May 18 '10 at 5:12
Ok, what does "quite recently" mean, then? Did the symptoms appear after an update? Was the system updated to 10.04 from 9.10 or full (re)install? – Jawa May 18 '10 at 5:42

Trying to fix broken package depedencies by running apt-get -f install gdm might fix the situation, if the system is updated from a previous version (<= 9.10).

As Ubuntu 10.04 uses Upstart (/etc/init) in place of InitV's scripts (/etc/init.d), you should check the contents of /etc/init/gdm.conf. It should list the appropriate runlevels when to start GDM e.g. start on runlevel 5.

share|improve this answer
This is a fresh install. In the gdm.conf file I see "start on (filesystem and started dbus and (graphics-device-added fb0 PRIMARY_DEVICE_DISPLAY=1 or drm-device-added card0 PRIMARY_DEVICE_FOR_DISPLAY=1)" Does that mean that it's not finding the rights conditions for starting? – Mike B May 18 '10 at 6:22
Right, it wasn't so simple, forgot about the other conditions... Yes, it seems to me that not all conditions are met, but I don't know how to see which. Maybe logs in /var/log/gdm/ say something? – Jawa May 18 '10 at 6:38
On my Intel integrated graphics touchscreen with Ubuntu 10.04 LTS, after an apt-get upgrade, gdm won't start anymore. sudo less /var/log/gdm/:0-slave.log shows 3 lines, the first being gdm-session-worker[1040]: GLIB-GObject-CRITICAL: g_value_get_boolean: assertion 'G_VALUE_HOLDS_BOOLEAN (value)' failed. – Cees Timmerman May 8 '12 at 13:31
I rebooted and still ended up at a blank black screen with an undecorated terminal window in the upper left corner. Alt+F1 to login at a text console and sudo ps x |grep gdm show gdm-binary, gdm-simple-slave, and X auth gdm aotaIM or something, and gdm-session-worker running, so i have a different question. – Cees Timmerman May 8 '12 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .