Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like to configure my keys my way, so I wrote a keyboard symbols file and I put it in

`/usr/share/X11/xkb/symbols/cat`

I use it by running setxkbmap cat -variant dvorak (and it works), but it doesn't show up in the console configuration (dpkg-reconfigure console-setup) nor in the Gnome keyboard settings... nor anywhere else, so I have to run setxkbmap every time.

I suppose that I have to register it somewhere, but where?

share|improve this question

migrated from stackoverflow.com May 18 '10 at 10:10

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

Ah, for Gnome to recognize it I had to add it to:

/usr/share/X11/xkb/rules/{base,evdev}.{xml,lst}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.