Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running gnome under Ubuntu Lucid

$ env | grep TERM
TERM=xterm
COLORTERM=gnome-terminal

I had to edit both my .muttrc and my vim colorscheme to change the background color from black to none in order to get a proper black background (or, more accurately, to retain the terminal's default black background). Setting it to black resulted in a dark grey background. This only happens with gnome-terminal; konsole, xterm and rxvt are fine.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I found a solution to this. I'm now using GNOME Terminal 2.32.0 and it still has the same problem. I fixed it by changing the color pallete. From the Edit menu, select Profile Preferences, then the Colors tab. Click on the upper left rectangle in the Color pallete, Palette entry 1. This has a default Color name of #2E3436. Change this to #000000. Voila!

share|improve this answer
    
perfect, thanks! –  Martin DeMello Jan 23 '12 at 1:22
    
Great, thanks - I've been battling between the server dishing out bad colours or vim setting them wrong, or setting the wrong terminal type! This is the real problem - the default 'black' for Gnome terminal is actually grey! –  J.Churchill Dec 13 '12 at 13:34
add comment

Do you have Transparent Background set to non-maximum under Edit > Profile Preferences > Background?

share|improve this answer
    
no, i have my background set to solid black. the terminal itself is fine; it's only when i start vim up with a colorscheme that uses ctermbg="black" that the background changes to grey. in other words, it's interpreting the color setting "black" as a dark grey color. i checked the palette too, but that seemed fine. –  Martin DeMello May 19 '10 at 8:55
add comment

This is a bug. A fix was released for Maverick in gnome-terminal 2.30.

https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/549552

share|improve this answer
    
thanks, good to know! –  Martin DeMello Aug 15 '10 at 8:41
1  
I'm running gnome-terminal 2.30.2 and the bug, or at least the same symptoms, are still there. –  garyjohn Nov 28 '10 at 1:00
    
still there in gnome-terminal 3.0.1 –  Martin DeMello Oct 1 '11 at 3:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.