Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi when i enter:GRANT ALL PRIVILEGES ON . TO 'yourusername'@'localhost' IDENTIFIED BY 'yourpassword' WITH GRANT OPTION; I get:The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement. What should i do to off skip-grant-tables option? Thanks.

share|improve this question
up vote 2 down vote accepted

Check mysql configs in /etc/mysql/ or the runscript in /etc/init.d/ .


Edit:
Try this: GRANT ALL, GRANT OPTION ON . TO user@localhost;

http://dev.mysql.com/doc/refman/5.1/en/grant.html

share|improve this answer
    
What should I check? – Yosef May 19 '10 at 18:50
    
Oh sorry the vm have been fixed now. Will report soon. – Shiki May 19 '10 at 20:26
    
Check edit...... – Shiki May 19 '10 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .